Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My friend has a desktop with Windows XP installed, and he does not have a UPS set up. Yesterday, the power went out and the PC underwent a hard shutdown. This caused a problem, (ntldr disappeared), but this was fixed by using an XP repair disk.

After he logged in again after the repair, he wanted to change some services, so he went to services.msc and got an error saying Your currently security settings prohibit running ActiveX controls on this page. As a result, page can't display correctly. as shown in this picture:

enter image description here

I ran a search on Google for the error, and found a registry edit, but it failed to solve the problem. The suggestion was to change the value of the 1200 key in HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Zones\0 from one to zero, but it was already at zero, so I set it to one, restarted, then set it back to zero and restarted again.

The same thing happened to me a few months ago on Windows 7, but I didn't notice it and formatted my OS for other reasons.

How can I get rid of this error message?

share|improve this question

My guess is that you have file corruption. I would first do a chkdsk /f at least a couple of times (most people don't realize that you often need to run this more than once), and if I still had problems, then I would do a System Restore too.

Here is how to check your chkdsk results:

They never stop reporting finding some things, but when it gets down to finding only around 5 items, is when I stop running it.

share|improve this answer

The services.msc in Extended view (tabs at the bottom) uses a HTML page and in it an ActiveX to display the services. If you use the Standard version, no HTML is used and you should be able to control the services. Not a real fix, but at least you can control the services for now.

As Internet Explorer is itself based on a lot of ActiveX control (see Wikipedia), an error in one of them can render the entire browser useless. This would also match the error that you even can’t start it.

The first thing would be a check of all system files used by Windows. Enter this command into Start - Run


(more details here)

If this does not work, try to update Internet Explorer to a newer version. I have seen a lot of broken IE6 installations with weird error messages that went away when installing Internet Explorer 7 or 8 - download here.

share|improve this answer

It is an internet explorer message. Try going to internet explorer/internet options/security, and set it as low as possible (you might want to turn off protected mode).

share|improve this answer
Didn't work at all. even unable to launch Internet Explore even I'm clicking on it a shortcut is appearing on desktop with name IE and as I clicking more the shortcuts are appeared in row with IE(1), IE(2).............. So i did it from Control panel but not succeeded. – avirk Jul 28 '11 at 7:50

I solved this problem a couple of minutes ago by going to Control Panel => Internet Options => Advanced tab and clicking the Reset... button under Reset Internet Explorer Settings.

Before hitting on the solution I spent several hours searching for hints on google, but I only found the answer when searching for something I thought only tangentially related to my problem.

I first searched directly for answers related to Security Zone, Services and Applications, ActiveX components and the differences between the Extended and Standard View. I searched for the causes of the Custom Level button being greyed out in Internet Options Security tab, but that turned out to be an unrelated problem.

Since I had this problem on a Windows XP Embedded build, I searched for information on the embedded components associated with the Services MMC. I of course searched for the phrase in the error message I got, which was that the ActiveX controls could not be displayed because of Internet Explorer security settings prohibit controls or blocked a publisher causing the dialog not to display correctly.

I finally searched for what activex controls are needed for services extended view, and amongst the results I found the solution to my problem.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .