Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to view this page in IE9. It has flash videos embedded but for some reason the Quicktime Plugin, not the Flash plugin, is being used to play them (which obviously doesn't work, and Quicktime throws an error). How can I tell IE9 to use the proper plugin? I have Flash installed and updated to the latest version. Rudimentary troubleshooting such as using compatability view does nothing.

Here's the embed code the site is using:

<embed src="http://blip.tv/play/huARgpiyHwA%2Em4v" 
       type="application/x-shockwave-flash" height="360" width="580" 
       allowscriptaccess="always" allowfullscreen="true"></embed>

A few additional items of information:

  • I'm using Windows 7 and opening the MIME/File Type Settings for Quicktime just brings up the Windows Control Panel for filetype associations. There is no option for Flash content or .swf that I can see.
  • Reinstalling Flash doesn't fix the problem.
  • Disabling the Quicktime plugin from the IE addons window doesn't correct the behavior, instead IE simply doesn't load any plugin at all.
  • Uninstalling Quicktime DOES work. With no Quicktime on my system IE will use Flash just fine. Unfortuantely however, I need to keep Quicktime around.
  • The page I linked is the only page I've seen that has this problem. Every other Flash video I've seen on the internet has played properly.
  • This might be an IE-specific bug, since Firefox plays the media properly with the Flash plugin.
share|improve this question

3 Answers 3

This site has various tutorial videos that have the same problem. I haven't found a solution to this either other than uninstalling Quicktime. Not sure what the heck is going on here.

CGTuts - IE9 Flash or Quicktime player confusion

Plays just fine in Chrome and Firefox.

share|improve this answer

It plays in Flash for me on Google Chrome. It sounds like flash video is associated with Quicktime on your computer.

Alter your Quicktime settings:

  1. Start the Quicktime Player.
  2. Go to Edit > Preferences > QuickTime Preferences
  3. Select the “Browser” tab and hit the MIME Settings button.
  4. Under the Video column, make sure that both QuickTime Movie checkboxes are ticked.
  5. Now go to miscellaneous and uncheck the Flash Media option.
  6. Click on OK button. Now
  7. go to the File Types tab
  8. Perform step 4 and 5
  9. Also, under the streaming tab, select automatic and check instant on.

(from: http://forums.techarena.in/windows-software/1403202.htm#post5259013)

Also, you might try re-installing flash. Likely, this will re-associate flash content with Adobe Flash again.

Clean Uninstall: http://kb2.adobe.com/cps/141/tn_14157.html

Install: http://get.adobe.com/flashplayer/

share|improve this answer
    
Neither of these options worked for me. Clicking MIME Settings and File Types in Quicktime both open the Windows Control Panel for file associations (I'm on Win7), and there's no option for Flash Media, not even .swf. I tried reinstalling Flash, and no luck. Uninstalling Quicktime did the trick, but unfortunately I'm forced to reinstall it if I want to use iTunes again. Note that the page that I linked is the only place where I've seen this bug happen, every other page plays Flash fine. –  jbpjackson Jul 29 '11 at 15:49

I was having a similar issue and what helped where the video was playing in Quicktime even though the default set for .mp4 files was Windows Media Player.

It would either load very slowly before playing or not at all, and I did the following to fix it.

  1. Start the Quicktime Player.
  2. Go to Edit -> Preferences -> QuickTime Preferences.
  3. Select the Browser tab.
  4. Uncheck Play movies automatically. Click Apply and then Ok.

Went back to my problem video and this time it played fine and using desired player.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.