Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an extremely strange issue.

Up until 3 weeks my Intermec device functioned perfectly on my HP Elitebook Windows 7 machine. Then for some reason I started getting "USB Device Not Recognised" message. I went through the normal troubleshooting

  • Uninstall USB Hub and let everything re-install
  • Re-install drivers
  • Tried different ports

I then got hold of another colleagues device (exactly the same device) plugged it in and it worked fine. I tried my device on his laptop (exact same spec/make and OS) and it worked absolutely fine.

I then replaced my motherboard on the laptop to see if there was some issue with the USB ports however it still shows the same issue.

I suspect it is perhaps a corrupt registry entry somewhere as I have replaced all the USB inf files in case they were corrupted and still the same issue.

Has anyone had similar USB problems? If so how did you solve them?

share|improve this question
    
Have you checked it on other system? But it seems like problem in USB connection not in the system. Check it on other system, if it still doesn't work then it is the problem in USB device. –  user222914 May 16 '13 at 6:54
    
This might be a dirty answer but I'm surprised you haven't tried an OS reinstall yet. –  bigbadonk420 May 16 '13 at 6:56
add comment

3 Answers

I would do three things:

  1. A System Restore to at least 3 weeks back, before the problem started.
  2. sfc /scannow from an elevated command prompt
  3. chkdsk /f from an elevated command prompt at least twice
share|improve this answer
add comment

Try this:

  1. Type in devmgmt.msc in run or the search box of the start menu.
  2. On the list of devices show, click on the drop down for Universal Serial Bus Controllers
  3. From the list shown, right click one of the ones labelled USB Root Hub, and click on Properties
  4. In the dialog box shown, click on the Power Management tab on the top right
  5. Uncheck Allow the computer to turn off this device to save power.
  6. Do the same for the rest of the devices labelled USB Root Hub
  7. Reboot.
share|improve this answer
add comment

Strange, try reinstalling the OS after replacing the motherboard. Test few USB devices (pendrives, external drives)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.