Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using Boot Camp to run Windows 7 on my MacBook Pro. Shortly I installed Tuxera NTFS to gain write access on NTFS formatted drives. Since then I cannot select the Boot Camp partition in the system settings as my boot drive any more. Pressing Alt during bootup works fine, but this way I would have to select the Windows partition manually every time I restart the Mac. How can I get this entry back?

Edit: I just uninstalled Tuxera. The Boot Camp partition is back. But the problem still persists: I need the NTFS driver. Is there any known way to solve this problem?

share|improve this question
add comment

2 Answers 2

up vote 3 down vote accepted

From the Tuxera FAQ:

Why does all NTFS drives disappear from the “Startup Disk” preference pane after installing Tuxera NTFS for Mac?
Apple does not allow any volumes that are mounted with third party file system drivers to appear in the “Startup Disk” preference pane. This is hard coded, and something that we cannot change. However, there are numerous alternative methods for booting into Windows:

  • Hold down the Option key during boot (or Alt for non-Apple keyboards). This brings up a boot menu where you can choose which volume to start your computer from.
  • Install the rEFIt boot manager for better control of the boot process.
  • Disable Tuxera NTFS for Mac (using the preference pane), unmount your NTFS volume with Disk Utility and mount it again.
    Your volume will now be mounted with Apple’s read-only NTFS driver, and the “Startup Disk” preference pane will behave as usual. Make sure to reenable Tuxera NTFS for Mac afterwards.
  • Use the command line utility bless to set the disk that should be used as default startup disk (see man bless for more information).

I've used rEFIt in the past (pre-Lion) with great success on a triple boot.

share|improve this answer
2  
Thanks. Meanwhile I found another tool, called BootChamp, which does exactly what I want :). –  Ulf Klose Jul 31 '11 at 14:46
add comment

You can also disable Tuxera for that specific volume. System Preferences > Tuxera NTFS > Volumes tab, select the BOOTCAMP volume and check "Disable Tuxera NTFS".

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.