Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have been trying to get vmware tools support successfully configured and started in my Ubuntu 11.04 guest. I am running a current version of vmware workstation on Windows 7 64 bit Ultimate with an Ubuntu 11.04 guest install. This VM was created using the easyinstall option in vmware workstation.

I have manually reinstalled and reconfigured vmware tools with the follwoing results.

last bit of relevant output following the vmware-config-tools.pl execution.

Creating a new initrd boot image for the kernel.
update-initramfs: Generating /boot/initrd.img-2.6.38-8-generic
initctl: Job failed to start
Unable to start services for VMware Tools

syslog output following reboot when vmware tools service fials

Jun 21 17:44:33 ubuntu tpvmlpd[17011]: bad device "/dev/**" given
Jun 21 17:44:33 ubuntu init: vmware-tools pre-start process (16816) terminated with status 1

I am hoping someone has some ideas.. Thanks, Pat

share|improve this question

migrated from stackoverflow.com Jul 28 '11 at 13:57

This question came from our site for professional and enthusiast programmers.

2 Answers 2

Try

sudo apt-get install linux-headers-virtual
sudo apt-get install --no-install-recommends open-vm-dkms
sudo apt-get install open-vm-tools
sudo vmware-toolbox
share|improve this answer
    
This had no effect. Same error message in syslog. –  Gabriel Hurley Jul 20 '11 at 19:33
    
I had already installed all this as well, same error.. I have also traded emails with vmware's linux tools point of contact and still have not gotten past this issue. They just have poor support for Linux guests. –  apesa Jul 21 '11 at 14:53
    
@apesa: Give my answer a shot :) –  TkTech Jul 25 '11 at 20:51

The error in question is from the ThinPrint service, which you most likely (99% of cases) don't need at all. You can easily (and safely) disable it. Edit /etc/init.d/vmware-tools using your favorite text editor (which we all know is Vim) and comment out /usr/bin/tpvmlpd. Then restart it by running /etc/init.d/vmware-tools restart.

share|improve this answer
    
The file (vmware-tools) does not exist (at least on my VM). Is that expected? From where else would the ThinPrint drivers be started? –  Bill Craun Jul 27 '11 at 18:47

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.