Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Windows 7 x86 PC and an Android phone with a 4G connection.

I would like to share the 4G connection – I currently do so using PDAnet software – but I also want to share it over my home LAN.

How would I go about sharing/hooking up my 4G connection through my 4-port Netgear N300 WNR3500 wireless router router?

In my LAN, there are three other PCs. All of them are going to be hard wired, maybe one or two wireless.

share|improve this question
    
Wouldn't it be easier to just share the 3G connection over WiFi? Android 2.2 supports this out of the box. –  dbkk101 Jul 28 '11 at 19:44
    
@dbkk101 - It's a hell of a lot slower, though. –  Shinrai Jul 28 '11 at 19:47
    
@dbkk101: Yeah don't want to do the wifi from the phone. Want it to be hard connected to the computer itself like it is. Just need to be able to share it though the router. –  StealthRT Jul 28 '11 at 19:48
add comment

2 Answers

If the machine it's shared with is already getting the 4G connection and using it properly for internet, it's probably easiest just to set up Internet Connection Sharing on that connection over the LAN in Windows 7. (It's possible I'm misreading you regarding the connectivity here, in which case please clarify.)

share|improve this answer
    
No that's correct but when i do that it doesn't seem to share it. I check the other pc on the router and it has no internet access. And the one the 4g is connected to does so its not that. –  StealthRT Jul 28 '11 at 21:20
    
Try manually configuring it to use that machine as the proxy server. –  Shinrai Jul 28 '11 at 21:38
    
Do you happen to have an example of that? :o) –  StealthRT Jul 28 '11 at 21:41
    
On my phone ATM and can't remember exactly what it looks like, sorry. Those directions mentioned the proxy settings IIRC though –  Shinrai Jul 28 '11 at 22:30
add comment

Make sure that your router is setup to get it's internet connection through your 4G connected computer. Check the Gateway settings on the router.

You can also try Bridging the 4G and Wired ports on that machine if ICS isn't working for you.

Good luck!

share|improve this answer
    
+1, might be the router. –  Shinrai Jul 28 '11 at 22:31
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.