Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have Suse server running on one of my lan machines ,localhost, and it is running Websphere application server. I am also running an http apache on the same machine. I have configured my wireless router to open port 80 for my site on the apache on my localhost, and opened port 90 to access an application i am running on the websheper server. Now when i access my real ip address from the internet, with the default port 80, i can see my site. but when i access port 90, i don't get to my application. I have opened port 90 on the firewall, and doing correct port forwarding on my router.

Can anyone help me in figuring out why this is the case... thanks guys

share|improve this question
    
Can you access port 90 from localhost and another computer on the LAN? One common practice with Java applications is to use Apache to do a local reverse proxy instead of opening a new port on the firewall. –  billc.cn Jul 28 '11 at 21:39
    
what happens when you run nmap? if everything is open and a service is indeed running on that port, nmap will say 90 is open. –  MaQleod Jul 28 '11 at 22:52
    
Yes, I can access the application on port 90 from another computer on the LAN. I don't have nmap but i am sure the port is open and listening and service is running. –  Amer Jul 29 '11 at 12:49
    
how can use Apache to do local reverse proxy, is that better than opening a port on the firewall? Thanks guys –  Amer Jul 29 '11 at 12:50

1 Answer 1

Have you checked your Virtual Hosts settings?

In the ISC navigate to Environment -> Virtual hosts -> "your_virtual_host" -> Host Aliases

("your_virtual_host" would be the virtual host name as defined for the application.)

There you would define the host name + port combination used for this virtual host. If e.g. you only have "localhost" defined as host name, accessing from outside via an IP or different host name would not work. If you do not want to differentiate for various applications, put a "*" for the host name to accept all host names.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.