Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I stumbled across a big problem, when I tried to make a VLAN work over a wireless connection between two MikroTik SXTs, and a Wireless AP at the end of this connection.

The setup is like that:

DHCP-Server ------- SXT ====== SXT ---- AP

LAN  ---
WLAN ===

In this Setup multiple Access Points should be serverd by a single DHCP Server and are interconnected through a VLAN backbone. Without the Wireless MikroTek Bridge, by only using patch cables, everything is fine, but when I use the wireless bridge, the DHCP Reply is blocked at any of the MicroTek devices.

First I thought it was the missing VLAN configuration on the MicroTeks, but when I add tmen nothing changed, I used the following configuration on both mikroteks:

interface vlan add name=vlan1 interface=bridge vlan-id=1001 disable=no
ip address add address=192.168.160.12/24 interface=vlan0

The bridge and wireless config is like follows (just for documentation):

system reset-configuration

interface bridge add name=bridge
interface bridge port add bridge=bridge interface=wlan1
interface bridge port add bridge=bridge interface=ether1 

ip address add interface=bridge address=192.168.151.14/24
ip address edit number=0 value-name=address
  192.168.88.1/24 -> 192.168.88.2/24

interface wireless set country="germany 5.8 fixed p-p" mode=station-pseudobridge ssid=XXX numbers=wlan1
interface wireless security-profiles add name=p1 authentication-types=wpa2-psk wpa2-pre-shared-key=xxx
interface wireless set security-profile=p1 numbers=wlan1
interface wireless enable numbers=wlan1

Has anyone an idea what I could have missed? Thanks!

share|improve this question
up vote 0 down vote accepted

Well I solved the problem in the end by using a the wds-mode=dynamic interface option:

system reset-configuration

interface bridge add name=bridge
interface bridge port add bridge=bridge interface=wlan1
interface bridge port add bridge=bridge interface=ether1

ip address add interface=bridge address=192.168.151.11/24
ip route add gateway=192.168.151.1

interface wireless set country="germany 5.8 fixed p-p" mode=bridge   ssid=ALARM-BR-BHP numbers=wlan1 
interface wireless set wlan1 wds-mode=dynamic wds-default-bridge=bridge
interface wireless security-profiles add name=alarm authentication-types=wpa2-psk wpa2-pre-shared-key=alarmkey
interface wireless set security-profile=alarm numbers=wlan1

interface wireless enable numbers=wlan1
share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .