Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I intend to assign a static IP to my Windows 7 system. I do this using Local Area Connection > Properties > TCP/IPv4 > Properties > provide the IP, subnet mask and default gateway.

However when I click OK and get back to the main menu, the diagnostics report says:

DHCP is not enabled for "Local Area Connection"

Am I missing something here?

share|improve this question
    
Can you please post a screenshot to be sure that you are entering it in the correct place? (You may need to post the link to the photo as plain text until you get a second vote on the question, thus giving you >10 rep and allowing you to post it as a picture in the question.) –  Synetech Jul 29 '11 at 2:12

4 Answers 4

up vote 0 down vote accepted

Try this:

Let Windows turn on DHCP. Next, go to the Network and Sharing Center and press Change Adapter Settings. Right-click "Local Area Connection" and select Status. Press Details.

Write down your:

  • IPv4 Address - Your computer's address.
  • IPv4 Subnet Mask - Identifies which IP addresses are neighbours and which are on other networks.
  • IPv4 Default Gateway - Your gateway to the Internet.
  • IPv4 DNS Server - Translates names like www.google.com into IP addresses like 74.125.237.49.

Close this window. Now you can set you static IP address.

Type in the same Subnet Mask, Default Gateway, and DNS Server as you had before. Your subnet mask will probably be 255.255.255.0. If so, then the first three numbers in your IP Address must stay the same as the DHCP assigned address. For example, if you had 192.168.0.100, you must use something like 192.168.0.xxx, where you can choose xxx.

share|improve this answer
    
I followed the above mentioned steps and the issue is now resolved. –  user682765 Jul 29 '11 at 17:42

It sounds like you're setting the wrong static IP address, netmask, and / or gateway.

The diagnostics tool wouldn't complain if it was able to make network connections, but since it cannot, it assumes that the reason is that you made the mistake of assigning an incorrect IP address on a network where your computer should receive its IP address using DHCP. It may not be right about the last part.

You should re-check the network settings; get in touch with the person in charge of the network and have them verify the settings for you and/or help diagnose the issue.

share|improve this answer
    
Well, I did an ipconfig and provided the same IP address, subnet mask and gateway which did not help. (would that be a wrong thing to do?) –  user682765 Jul 29 '11 at 2:57

Don't hit diagnose. If you set a static IP and then let the OS diagnose your iP "problem" it is ALWAYS going to suggest you turn DHCP on.

Which makes sense. If you put in the right static IP address and you can't get internet, either you put in the wrong IP address or it has nothing to do with your computer and the problem is else where.

After you put in a static IP, you don't need to reset the network card or anything. The network packets will automatically be routed to whatever settings you put in.

share|improve this answer
    
If I do not hit diagnose, then it will not complain then. But after reboot, it will not connect to internet complaining with the same problem. –  user682765 Jul 29 '11 at 2:55

This error is not bound up with good or wrong settings of IP address, mask etc.

Possible cause: dhcp service stopped, virus blocking dhcp service. Try reseting the dhcp service.

  • Do u have other NIC in this machine? Try setting the same "numbers" on other NIC or on other machine.

  • try to disable IPV6 also.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.