Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have nomodeset when I boot my kernel, as I want to switch between nouveau and nvidia proprietary drivers within a session.

However, nouveau won't load, complaining that kms isn't enabled (xorg.log excerpt):

(II) NOUVEAU driver Date:   Tue Mar 16 13:08:37 2010 +1000
(II) NOUVEAU driver for NVIDIA chipset families :
    RIVA TNT    (NV04)
    RIVA TNT2   (NV05)
    GeForce 256 (NV10)
    GeForce 2   (NV11, NV15)
    GeForce 4MX (NV17, NV18)
    GeForce 3   (NV20)
    GeForce 4Ti (NV25, NV28)
    GeForce FX  (NV3x)
    GeForce 6   (NV4x)
    GeForce 7   (G7x)
    GeForce 8   (G8x)
(II) Primary Device is: PCI 01@00:00:0
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is 7, (OK)
drmOpenByBusid: Searching for BusID pci:0000:01:00.0
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is 7, (OK)
drmOpenByBusid: drmOpenMinor returns 7
drmOpenByBusid: drmGetBusid reports pci:0000:01:00.0
(II) [drm] nouveau interface version: 0.0.15
(EE) [drm] KMS not enabled
(EE) No devices detected.

Here is the lsmod:

$ lsmod | grep nouv  
nouveau               353208  0 
ttm                    40978  1 nouveau
drm_kms_helper         20369  1 nouveau
drm                   143329  3 nouveau,ttm,drm_kms_helper
i2c_algo_bit            4225  1 nouveau
i2c_core               15819  5 nouveau,drm_kms_helper,drm,i2c_i801,i2c_algo_bit
button                  4650  1 nouveau

Am I missing something or isn't it possible to have nouveau without KMS? I have done a bit of searching, and everything I find points me back to enabling kms in the kernel.

Linux zen 2.6.32-5-xen-amd64 #1 SMP Tue Jun 14 12:46:30 UTC 2011 x86_64 GNU/Linux
share|improve this question
    
After framing the question, I considered an alternative search and found the answer: nouveau.freedesktop.org/wiki/KernelModeSetting. I don't have rep to answer however. –  Paul Jul 29 '11 at 14:43
add comment

2 Answers

https://wiki.archlinux.org/index.php/Nouveau#KMS

Kernel Mode-Setting (KMS) is required by the Nouveau driver. See the KernelModeSetting page for more information.

It's from the Arch wiki, but it's true for all systems. You cannot use nouveau without KMS.

share|improve this answer
add comment
up vote 0 down vote accepted

The nouveau driver requires KMS to run, so it isn't possible to use it when nomodeset is set on the kernel boot line in grub.

The right way to remove the driver after boot is to disconnect the framebuffer from the driver as described here:

http://nouveau.freedesktop.org/wiki/KernelModeSetting

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.