Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just installed a copy of XP I had lying around into a VM using virtualbox. I then loaded a game disc (syberia -- awesome game) and proceeded with the install.

However, when I click the .exe, Windows gives me the following error:

The setup files are corrupted. Please obtain a new copy of the program.

What's going on?

share|improve this question
add comment

2 Answers

I've had this issue once before and I solved it by performing a full system update and getting the newest version of Windows Installer. In your case, I would recommend you try either a newer or older version of WI.

share|improve this answer
add comment

Try clearing your temp folders (CCleaner can help), uninstall syberia and reboot. Try re-installing once again, ensuring any security software is disabled during the install.

If the game requires OpenGL/DirectX (likely), you will have to install the Guest Additions first. Even then, these drivers are still experimental.

share|improve this answer
    
It never got installed though. This is when I click on the actual installer. Plus this is a 100% clean windows install. –  MaxMackie Jul 29 '11 at 17:39
    
Try the game disc on your host system -- does it produce the same error? –  John T Jul 29 '11 at 17:41
    
My host is a linux build (opensuse) but Wine can open the installer perfectly. –  MaxMackie Jul 29 '11 at 17:41
    
Odd, perhaps the CD emulation driver isn't passing the data correctly to the virtual machine. Try copying the CD install files to your Linux host then from there transfer them with a vbox share. –  John T Jul 29 '11 at 17:46
    
Just finished trying that. Same error occurs, very weird. I thought it might be an issue with Windows Installer but I'm not sure how to diagnose that. –  MaxMackie Jul 29 '11 at 17:47
show 3 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.