Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I set my Windows 7 taskbar to auto-hide. However, sometimes when a program changes or something new happens in a program, the taskbar will show its self, and its respective taskbar icon will begin flashing orange.

Here's what I'm talking about:

enter image description here

To make the taskbar hide again, I have click on the program before I can go back to what I was doing.

Anyways, I personally find this very annoying, and would love to find a way to either:

  1. Prevent the taskbar from having such alerts.
  2. Prevent the taskbar from showing its self when it has such alerts.

I've searched around quite a bit, and really only found answers to this for XP.

I've also found another Stack Exchange Question looking for the same thing for Windows 7. However, none of the answers to the question were really what I'm looking for. I'm not looking to hide the taskbar, or control the number of flashes.

However, this answer seems to be what I'm looking for, so I downloaded and tried out the program. It works perfectly, other than the fact that the start menu icon is always shown, regardless of the taskbar being set to auto-hide.

So, any ideas on how to fix this problem?

share|improve this question

2 Answers 2

up vote 25 down vote accepted

Steps to disable flashing icon on Taskbar - Windows 7

  1. Click the Start icon
  2. Type in regedit
  3. Select regedit from the top of the result
  4. Go to: HKEY_CURRENT_USER\Control Panel\Desktop
  5. Editing ForegroundFlashCount
    1. Find ForegroundFlashCount
    2. Double click ForegroundFlashCount
    3. Replace the value for Value Data with 1
  6. Editing ForgroundLockTimeout
    1. Find ForegroundLockTimeout
    2. Double click ForegroundLockTimeout
    3. Replace the value for Value Data with 0
  7. Reboot

This is the way to do it without any 3rd-party applications. The steps are in detail steps to help both experienced and non-experienced users. If you want to undo these changes, repeat the steps above using the original values: ForegroundFlashCount is 7; ForegroundLockTimeout is 30d40.

Disclaimer : You should always backup your registry before editing your registry.

share|improve this answer
    
ForegroundLockTimeout was already 0 before I touched it –  MarcH Sep 4 '13 at 12:38
2  
Didn't work for me, after changing these settings the default behavior persisted. –  ChimneyImp Sep 19 '13 at 15:23
    
In each DWORD dialog, do we leave Base as Hexadecimal or Decimal? –  Chris Schiffhauer Oct 23 '13 at 16:46
    
@PaulyGlott For values less than or equal to 9, it does not matter. If you were to revert to the original values, you would have to use Hexadecimal for the ForegroundLockTimeout value (30d40). –  Andrew Morton Jun 27 at 17:39

Try the free option given above. If it doesn't work, TuneUp Utilities 2011 has a feature to disable this:

enter image description here

It's not free, but they have a 15 day trial (so you can ensure it does work).

share|improve this answer
1  
I just tried out this program. Unfortunately, after using this setting and restarting my computer, the flashing still exists: i.imgur.com/d2g63.png –  Jeff Gortmaker Jul 29 '11 at 23:13

protected by Community Jul 30 '12 at 6:57

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.