Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using ubuntu 11.04. I have installed googlecl which claims to allow me to edit google doc files with vim. I have a google doc "test":

google docs edit --title "test" --editor vim

opens the file fine. When I write the file via the vim command :w the change isn't propagated to the original google doc in the cloud. Also, when I :wq, I get this command line output:

Server responded with: 412, <errors xmlns='http://schemas.google.com/g/2005'><error><domain>GData</domain><code>etagsMismatch</code><internalReason>Mismatch: etags = ["tags"], version = [gqpwmaue]</internalReason></error></errors>
Moved edited document to /home/james/test.txt

How can I automatically update the original doc when I save it in vim?

share|improve this question
    
I've never heard about googlecl so I installed it on Ubuntu 10.10 and I have almost the same problems. Maybe try on the googlecl issue tracker. –  romainl Jul 30 '11 at 12:02
add comment

1 Answer

I am not sure if you solved the problem, but I was encountering the same error on my machine. This was happening because I didn't have the latest python-gdata package. GoogleCL package alone won't do the job.

share|improve this answer
    
I made sure to use the 2.0.14 version of gdata. Apparently later versions have issues. But note that I /did/ come across your error before with this version - but I figured that was a connection or document-type-dependent thing, because afterward it worked fine. –  dmonopoly Nov 25 '12 at 19:01
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.