Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have two wireless cards in my computer. One bad one that cant be removed and one good one the I actually want use. Opensuses network manage automatically loads both and switches between the other which causes my internet connection to go out. I can temporarily disable the bad one with ifconfig wlan0 down, but this does not hold when I restart the computer. Wlan0 will pop back up a few minutes after i run that also making ifconfig a temporary solution. Is there a way to completely disable this interface? It is a ralink chipset.

share|improve this question

3 Answers 3

up vote 1 down vote accepted

Do you know the specs on the "Bad one?" If so, you should be able to use lsmod to find the driver that is used, and prevent it from being autoloaded.

share|improve this answer
    
I don't, it came built into this storebought computer. I know the other is a dlink dwa-556. Ok, I will try that tommorow. –  a sandwhich Jul 30 '11 at 3:36

You should disable the NIC in the BIOS so that the system will not even see it as an option.

share|improve this answer

You should be able to go into Network Manager (if that's what's running) and set the configuration for that device to not be enabled on boot.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.