Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to help fix a machine with Vista SP1. After installing this weeks Windows Updates the 32-bit apps on the machine no longer connects to the internet. If I run the 64-bit IE then it works fine. But 32-bit IE just says it's unable to connect and results in a crash dialog when quitting it. Same with any other 32-bit app that uses the internet.

Log entries:

Program med fejl iexplore.exe, version 8.0.6001.18813, 
tidsstempel 0x4a6621ae, modul med fejl unknown, version 0.0.0.0, 
tidsstempel 0x00000000, undtagelseskode 0xc0000005, forskydning med 
fejl 0x022e17d0, proces-id 0x5ec, 
programmets starttidspunkt 0x01ca280ea90f80a5.

Program med fejl firefox.exe, version 1.9.0.3498, 
tidsstempel 0x4a728f53, modul med fejl unknown, version 0.0.0.0, 
tidsstempel 0x00000000, undtagelseskode 0xc0000005, 
forskydning med fejl 0x028d00c4, proces-id 0x324, 
programmets starttidspunkt 0x01ca27f5d8ca22f5.
share|improve this question

2 Answers 2

up vote 0 down vote accepted

The access violation code "0xc0000005" (undtagelseskode) might be the clue here. In fact there's an article where exactly the same problem was discussed.

This article lists common reasons for crashes with "0xc0000005" exit code. Although the article is about Windows XP, one of the common reasons listed seems interesting, namely "Data Execution Prevention". This article looks deeper into problems caused by DEP.

Also try searching for the access violation code, it seems to be a quite popular one.

share|improve this answer
    
Thanks. Running 'netsh winsock reset' as pointed out in the first article solved the issue. –  user8970 Aug 29 '09 at 7:53

How can you have Vista SP1 with the latest Windows Updates? Vista is currently at SP2.
If you haven't updated to SP2 do so first, as it might fix your problem.

share|improve this answer
    
I have no idea. It's not my machine. SP2 was listed as an 2 months old update but apparently it wasn't auto-installed. –  user8970 Aug 30 '09 at 11:58
    
Then installing SP2 should be the first step. –  harrymc Aug 30 '09 at 19:42

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.