Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just lost my Wi-Fi router and ADSL modem to a lightning strike. To replace them I just bought a Belkin Surf Wireless Router and acquired a used but working ADSL modem.

The modem works great when I connect directly to it.

The Belkin seems to be working properly; the signal strength and coverage seems great. Except that all connections through it (Wi-Fi or wired) are extremely slow and unusable.

After searching around I see this is a fairly common problem. There is talk about using Google's DNS servers; this doesn't begin to help. There's talk about swapping the cable, that didn't help me either. There's talk about smaller MTUs and disabling firewalls and other random guesses. Nothing has helped me.

I can't get it to work nicely with either Linux or Vista.

Any ideas?

share|improve this question
    
To be honest, if you just bought it, and are having that much trouble, and it is so common on the Internet, I would take it back, and get a different brand. –  KCotreau Jul 30 '11 at 15:36
    
Alternatively, you can try upgrading the firmware to whatever belkin has to offer, or swapping it with something different altogether (dd-wrt.com/site/support/router-database). It could very well just be the software on the router that is causing the problem. –  MaQleod Jul 30 '11 at 17:29

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.