Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am rebuilding my work computer from scratch and need to add my domain user as a local admin on my computer. I have successfully added my PC to the domain, but I cannot add my domain user account to the local admins.

I have tried to do the following:

  1. Connect to the work domain using a Windows VPN
  2. Add my computer to the work domain
  3. Start > right click on Computer > Manage - go to Users and Groups > right click on Administrators group and add my domain user

The problem is that after adding my domain user to the Administrators group, I don't see my domain user under the Local Users group. When I try to log on as my domain user I get the following error message:

There are currently no logon servers available to service the logon request

Any ideas?

share|improve this question
add comment

3 Answers

To get past the "There are currently no logon servers available to service the logon request" error you will need to connect to the VPN before attempting to log on.

Set up the VPN connection to have "Allow other people to use this connection" enabled (you may have to recreate the VPN connection entry to do this).

Once this is done, log out. Then, at the log on screen, click the "Switch User" button. A "Network logon" button should appear in the lower right corner (next to the power button).

You use this to make your VPN connection first, so that when you log in the remote logon server will be available to authorize you.

More info on this is available here.

I'm not sure why your domain user won't stick to the local administrators group, but it could be prevented by your work's Group Policies. Check out this SU question for more info on that possibility.

share|improve this answer
add comment
  1. Login as the local administrator.
  2. VPN to your work domain.
  3. Add user via control panel (Advanced)

You'll only see your work's domain once you login to the VPN.

share|improve this answer
add comment

It is probably this:

Go to:

Control Panel>Network and Internet>Network Connections>Advanced>Advanced Settings

And set the binding order so that "[Remote Access connections]" is at the top. Assuming that you are picking up the Domain's DNS server for that connection, so you can resolve to Domain servers, this will force your computer to use that DNS server.

enter image description here

You can check what DNS server your VPN connection is using by doing an IPCONFIG/ALL and checking your DNS settings for the VPN connection while you are logged in. If they are not set to the Domain's DNS server, in the VPN connection, manually set it.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.