Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

After I turn on my machine, the first couple of Time Machine backups seem to go OK, but after about an hour I get this error:

Unable to complete backup. An error occurred while creating the backup folder.    
Latest successful backup: 7/31/11 at 12:32 PM

I'm running 10.7. Time Machine is backing up an internal HD to an external USB HD. I've already run Disk Utility to repair the Time Machine partition. It's a relatively new hard drive and didn't have any issues.

Here's what I've found in the Console's log filtered for backupd:

7/31/11 12:31:21.223 PM com.apple.backupd: Starting standard backup
7/31/11 12:31:21.447 PM com.apple.backupd: Backing up to: /Volumes/MyMac TM Backup/Backups.backupdb
7/31/11 12:31:29.146 PM com.apple.backupd: 983.7 MB required (including padding), 391.90 GB available
7/31/11 12:32:19.471 PM com.apple.backupd: Copied 3156 files (36.0 MB) from volume Macintosh HD.
7/31/11 12:32:20.017 PM com.apple.backupd: Copied 3173 files (36.0 MB) from volume LI.
7/31/11 12:32:20.136 PM com.apple.backupd: 934.8 MB required (including padding), 391.86 GB available
7/31/11 12:32:54.755 PM com.apple.backupd: Copied 916 files (117.8 MB) from volume Macintosh HD.
7/31/11 12:32:54.894 PM com.apple.backupd: Copied 933 files (117.8 MB) from volume LI.
7/31/11 12:32:55.937 PM com.apple.backupd: Starting post-backup thinning
7/31/11 12:32:55.937 PM com.apple.backupd: No post-back up thinning needed: no expired backups exist
7/31/11 12:32:55.960 PM com.apple.backupd: Backup completed successfully.
7/31/11 1:21:28.624 PM com.apple.backupd: Starting standard backup
7/31/11 1:21:28.631 PM com.apple.backupd: Backing up to: /Volumes/MyMac TM Backup/Backups.backupdb
7/31/11 1:21:28.682 PM com.apple.backupd: Error: (22) setxattr for key:com.apple.backupd.HostUUID path:/Volumes/MyMac TM Backup/Backups.backupdb/Will’s Mac Pro size:37
7/31/11 1:21:28.683 PM com.apple.backupd: Error: (22) setxattr for key:com.apple.backupd.HostUUID path:/Volumes/MyMac TM Backup/Backups.backupdb/Will’s Mac Pro size:37
7/31/11 1:21:38.694 PM com.apple.backupd: Backup failed with error: 2
share|improve this question
1  
The person in this thread just erased the drive and started over... – jtbandes Jul 31 '11 at 19:27
    
Same problem here. I replaced the drive, and started a new backup, but the problem was still there, then I updated to 10.8, erased the drive and start with clean backup, but the problem still exists. BTW, it always manages to complete the first backup after restart. – Ben-Uri Oct 23 '12 at 12:28
1  
There's a name resolution conflict going on, by the look of it. Will‚Äôs Mac Pro is failing when it tries to set an extended attribute, because setxattr is probably failing in finding a match on the name. Change the name of the machine (or hard drive) to exclude an apostrophe) and see if that works. – user3463 Oct 28 '12 at 18:49

Pondini via Apple Support Community

Re: Error Occurred while creating backup folder?

This is not a common error, but usually, +Repair Disk+ fixes it.

We've had a couple of cases where installing the "combo" update fixed it, but also a couple where it didn't. Info and download available at: http://support.apple.com/kb/DL1349 Be sure to do a +Repair Permissions+ via Disk Utility (in your Applications/Utilities folder) afterwards.

If that doesn't help, reinstall OSX from your Snow Leopard Install disc (that won't affect anything else), then apply the "combo" again.

Or, it may be a problem with the drive. Do you have another you can try?

share|improve this answer
1  
I've already tried repairing the disk and repairing permissions. Neither had any effect. I'm running 10.7 Lion so the 10.6.6 update doesn't really matter. I unfortunately don't have another drive handy. I guess I might try reformatting the backup drive now. – user92401 Aug 21 '11 at 17:45

I had this same problem on my MacBook Air.

The name of my backup volume is "MacBook Air Backup" and I notice that I had two folders in my \volumes folder:

MacBook Air Backup
MacBook Air Backup 2

I ejected my backup drive and the "MacBook Air Backup" folder was still present in my Volumes folder, so I used terminal to remove it like this:

sudo rmdir "MacBook Air Backup 2"

(There were several subfolders beneath it that had to be removed first.)

After doing this I reconnected my backup drive and was able to successfully complete the backup.

share|improve this answer

I have just experienced this problem on OS X 10.9.5; I had set up Time Machine with a new destination volume, and it backed up normally for three days. Then I got errors pretty much identical to yours on every backup attempt.

I found that I also couldn't create files on the backup destination volume via Finder or terminal. The error message in terminal was "xyz: invalid argument" where xyz was a file I was trying to create via touch or echo.

The permissions on the volume looked normal, so I decided to give the OS a fresh look at the volume by ejecting it (had to force eject), then remounting via Disk Utility. After that Time Machine completed a backup successfully.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .