Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I click on it, the cursor juts blinks for a second and nothing happens. Nothing Google related is found in task manager either. CPU and Memory usage levels are normal. Just started happening yesterday

  • Tried reinstalling
  • System restore's turned off (I never use it and it takes up space)
share|improve this question

closed as too localized by studiohack Aug 7 '11 at 17:42

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Or a System Restore? –  KCotreau Jul 31 '11 at 19:49
    
Tried reinstalling –  Alex Yan Jul 31 '11 at 20:02
    
System restore's off –  Alex Yan Jul 31 '11 at 20:02
    
Btw you need to @ mention users to have them receive notifications. /cc @KCotreau –  slhck Jul 31 '11 at 20:17
add comment

1 Answer 1

up vote 1 down vote accepted

Never mind. Fixed it using cmd

"C:\Users\<username>\AppData\Local\Google\Chrome\Application\<Chrome version>\Installer\setup.exe" --rename-chrome-exe

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.