Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I make a mistake one day: I made notepad the default application for opening .bat files. I've tried using cmd.exe to open a .bat file, but all it does is open a new window; it doesn't execute the script. How can I restore the default behavior for batch files? I'm using Windows Vista.

share|improve this question
add comment

1 Answer

up vote 3 down vote accepted
  1. Download and install Creative Element Power Tools.
  2. Open the Creative Element Power Tools Control Panel.
  3. Turn on the Edit file type associations option, and click Accept.
  4. Right-click a file of the type you want to change, and select Edit File Type to show this window:

alt text

Highlight .bat and remove it.

share|improve this answer
    
I had to create a new one, but the default settings seams to have worked, thanks –  matmat07 Aug 29 '09 at 1:11
    
you're more than welcome. –  Molly7244 Aug 29 '09 at 1:16
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.