Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I do a "Windows Help and Support Center" "Network Scan" on my XP SP3 machine, it tests a very long list of various things. All are marked "OK" except:

> Pinging, request failed

My router, and my Network Property tab are both set to, NOT

Other machines on my network correctly check, and report OK, when I do the same Network Scan.

Where would I set (fix) that value? Why does Windows think it needs to scan/check the WRONG address? (Thus failing.)



I did find these 8 wrong values in my registry:
> DhcpDefaultGateWay
> DhcpIPAddress  (.2 ????)
> DhcpNameServer
> DhcpServer
> DhcpDefaultGateWay
> DhcpIPAddress  (.2 ????)
> DhcpNameServer
> DhcpServer

Notice the "suggested DhcpIpAddress fix" isn't even ".1" anyway.

Sounds like things are pretty messed up for me.

share|improve this question

2 Answers 2

Open regedit as an administrator.

Check all the subkeys of the registry key below (they will be long and resemble this, "{9B5A7831-1D50-4353-9583-50C4245EF413}"):


As you check each subkey, look for this key in the right pane, "DhcpServer", with the value "". Double-click it and edit it to be "".

You may need to reboot. I am not sure.

share|improve this answer
I'll give that a try. Thanks! Any idea how my values got messed up? Virus? AntiVirus? – Susan Aug 1 '11 at 3:39
I cannot be 100% sure as to why, but virus is VERY unlikely. – KCotreau Aug 1 '11 at 3:44
Since you had so many bad entries (I figured there would be only one based on your question), why don't you go into device manager, and delete the adapter, and then scan for changes to re-find and re-add it. That will probably fix it. – KCotreau Aug 1 '11 at 4:30
> so many bad entries Huh? Do you mean the items in the Update? That’s likely because the router’s IP used to be and the NIC was using that, then she changed the router’s IP and now the NIC needs to be updated to reflect that. My guess is that she has a hard-coded static setting somewhere. – Synetech Aug 1 '11 at 5:16
I think that would be obvious if she had her IP address settings set statically, and I don't think that she would have gotten "DHCPServer (FAILED)". My thoughts were that it is somehow not finding and updating the DHCP server, and thus, the rest of the settings after. – KCotreau Aug 1 '11 at 5:20

The IP address in the registry entires you listed are .2 instead of .1 because those are for your system, while the ones with .1 are for the router. This is perfectly normal.

What you need to do is to go to Control Panel->Network Places, right-click your NIC/connection and select Properties. Now double-click IP4 (TCP/IPv4) (or select it and click Properties).

Are you using static settings or is it set to auto?

If you have static settings, check the gateway. Is it Change it to Also check the Alternate Configuration tab and make the same change.

If you are using auto settings (ie DHCP), click Advanced. Now look at the Default gateways list box in the IP Settings tab. What’s in there? If there is a, click Edit and change it to

Finally, if all else fails, do a search-and-replace in the registry (but don’t resort to that if you can avoid it by using the provided dialog interfaces to make the changes).

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.