Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to Remote desktop from Vista to Windows 7 to two machines on the same home workgroup.

On the Windows 7 box I have:

  • enabled the 'remote assistance' check box under computer > properties > advanced > remote
  • opened the firewall port
  • started the remote desktop services
  • rebooted

on the Vista client I have

  • telneted to the IP address on 3389 and got no connection open - I tried repeating this and switching off the firewall on the server and got the same result

I still can't connect. (I can see the machine in my workgroup, and ping it on the command line, and explore it's file directory) (I don't see it in my list of terminal servers when browsing in terminal services client)

What else should I try?

share|improve this question

migrated from serverfault.com Aug 1 '11 at 7:54

This question came from our site for system and network administrators.

    
Unless you have a particular need for 'Remote desktop' I might suggest trying one of the open source VNC programs (e.g. UltraVNC) - they offer more flexibility and, at least for me, have been easier to use and had a higher success rate. If your boxes aren't directly connected, check the (port-forwarding) settings on the network device (router?). –  cyberx86 Aug 1 '11 at 7:30
    
In honesty I'm getting the same issues with UltraVNC - connection doesn't open. Any suggestions? –  hawkeye Aug 1 '11 at 8:13
1  
It defiantly sound like firewall is telnet, rdp and vnc are all failing... try turning it completely off on both machines temporarily? –  Windos Aug 1 '11 at 8:17
    
ok - shutting down firewall on client and server enabled ultravnc to work - but not remote desktop. Thanks for that. Any suggestions on remote desktop? –  hawkeye Aug 1 '11 at 9:36
    
Is there any specific error message you get when trying to do the RDP connection? –  Windos Aug 1 '11 at 10:25

4 Answers 4

You need to enable Remote Desktop, not remote assistance. The option is on the same page as remote assistance.

share|improve this answer
    
Thanks for helping me clarify - I did have that set. –  hawkeye Aug 1 '11 at 7:59

Telnet to it from the other system at port 3389. If it fails to connect, then check your Windows Firewall configuration.

share|improve this answer
    
I tried this, and tried it with firewall switched off - and still got no result. Any other suggestions? –  hawkeye Aug 1 '11 at 7:59

What option do you have set under the remote options?

In that group should be three options, the default set to "Don't allow connections to this PC". Try changing it to "Allow connections from computers running any version of Remote Desktop (less secure)". This will mean you other PC can connect no matter what version of RDP it has.

It'll also pay to go into "select users" and make sure the account you wish to remote in as is present and if not add it/them.

enter image description here

It maybe easier to look into VNC if this fails.

share|improve this answer
    
This has been set the whole time - getting ultravnc issues as well. –  hawkeye Aug 1 '11 at 8:26
up vote 0 down vote accepted

Ok - as per the comment on this answer: Why can't I connect to my Windows 7 via Remote Desktop?

"Just as a side note, RDP is only available on the Professional (and higher) versions of Windows. Home versions are out of luck"

I happen to be running "Home Premium" on this server.

share|improve this answer
    
Out of curiosity, if you're running Home Premium how were you able to "enabled the 'remote desktop' "allow connections from computers running any version of remote desktop" radio button under computer > properties > advanced > remote" That whole section on the remote tab should be blank for you. –  Windos Aug 1 '11 at 10:47
    
Regardless, if the PC you're trying to remote onto is only Home Premium then you wont be able to connect to it using RDP (you can only connect to computers running Windows 7 Professional, Windows 7 Ultimate, or Windows 7 Enterprise) your only options in this case is VNC (which you got working above) or upgrade Windows 7. –  Windos Aug 1 '11 at 10:54
    
Thanks for that Josh. Fair call. –  hawkeye Aug 1 '11 at 11:57

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.