Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just installed vim on the windows machine, the executable file contained gvim and console vim. After running vim.exe I see this picture. enter image description here

The language is Russian but I don't know why only few symbols are displayed. Do you have any idea what's wrong?

share|improve this question
    
Is your whole system set russian? (Including default code page for non unicode programs) –  sinni800 Aug 1 '11 at 14:16
    
yeap, that's right –  Sergey Aug 1 '11 at 14:17
    
Other programs display russian correctly in the command window? Also: What kind of VIM is it? Cygwin? Directly compiled to Windows APIs? –  sinni800 Aug 1 '11 at 14:19
add comment

1 Answer

Did you choose a font for vim that contains all the Cyrillic characters and is mono-spaced? For example "Courier New (Cyrillic)"

There's some good advice at nabble

To see cyrillic characters in Console Vim you need a terminal with Cyrillic display, since Console Vim can only use whatever characters the underlying terminal offers.

In gvim, you can display Cyrillic characters on two conditions: - 'encoding' must be set to some value which supports Cyrillic text. This can be an 8-bit encoding like koi8-r, cp1251 or ISO-8859-5, or a multibyte encoding like UTF-8. - Your 'guifont' must include Cyrillic glyphs. Lucida_Console has a problem in that its Cyrillic bold glyphs are slightly wider than its unbold glyphs. Courier_New is uglier but "saner".

(Update:)

In the Vim download page there are

iconv library libiconv

A library used for converting character sets. Put "iconv.dll" in the same directory as gvim.exe to be able to edit files in many encodings. You can find the dll file in the bin directory of the "libiconv-win32" archive.

newer intl library libintl

The included libintl.dll does not support encoding conversion. If you have installed the iconv library, as mentioned above, you can install a gettext library that uses it. Get "intl.dll" from the bin directory in the gettext-win32 archive and store it as "libintl.dll" in the same directory as gvim.exe, overwriting the file that may already be there.

PC translations vim##lang.zip vim72lang.zip

Only for 7.2 and earlier, for 7.3 these are included in the "rt" archive. Translated messages and menu files, packed for the PC. Use this to see non-English menus. The messages are only translated when the libintl.dll library is installed.

share|improve this answer
    
I tried both :set encoding=utf-8, setting encoding in _vimrc file, setting it to cp1251(which supports cyrillic), utf-8, utf-32, nothing changed. There are still strange characters instead of symbols. –  Sergey Aug 1 '11 at 19:35
    
yeah, I've read that post. gvim displays cyrillic symbols properly. The windows command line(cmd.exe) also support cyrillic characters, but the picture appears anyway. –  Sergey Aug 1 '11 at 19:41
    
Is this Vim 7.3 32-bit from vim.org/download.php#pc ? –  RedGrittyBrick Aug 1 '11 at 19:45
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.