Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm stuck using word 2007 at the office. It has options for retaining formatting, pasting as plain text, and pasting text to match the destination's formatting. That last option is the one I want, but word is blatantly ignoring it.

I copy some text from a PDF, paste into word, and it retains the PDF's formatting... even though I went into options --> advanced --> changed all the dropdowns to "Match Destination Formatting". It also ignores "text only" option... It retains the exact mix of bold, italic, normal text & fonts.

I can work around it by pasting to a plain text file, then pasting into word. Or I can do paste special --> unformatted text. But this is so irritating... I just want to ctrl+V and not hassle with it every single time. Is there a better fix?

share|improve this question
add comment

4 Answers

up vote 1 down vote accepted

The answer of KCotreau is correct and works for the cases I tested it.

However, if does not work in your case you might want to give PureText+ a try. This utility tries to extract only the text from the current clipboard content and paste it into the active application.

Usage is rather simple:

  • Start PureText+
  • Copy the desired text to the clipboard
  • Switch to Word and press WINDOWS + V
share|improve this answer
    
I'm going to mark this as the answer, it works and I can use it elsewhere. Using word's options has been very flaky. I think it's the styles issue mentioned earlier, or maybe there's an empty space after my text that's formatted differently (e.g. default word times new roman) than the rest, and when I paste at the end of the line it takes on that formatting instead of the preceding formatting. Something weird: if paste using this app, then undo, then do a ctrl+V, it's plaintext and works as desired. Thanks again for the link. –  CreeDorofl Aug 3 '11 at 18:35
    
Thank you. What is funny about this question is, that I was using PureText+ at home but couldn't at work. If you copy a lot from websites I have always forced to use the Notepad trick. The option @KCotreau found solved my copy problems and I can stop using PureText+. What is the saying? Your mileage may vary :) –  TeX HeX Aug 3 '11 at 19:47
add comment

Since there are four different options to set the various paste options, and you did not say which one, I am not sure if you set them all, and it did not work, or if you set the wrong one.

This SHOULD work, and worked for me when copying from Adobe Acrobat Reader to Word 2007:

I went into Office Button>Word Options>Advanced>Paste from other programs (the forth one down) and set it to "Keep text only", and it worked perfectly.

enter image description here

share|improve this answer
    
Awesome find. I was searching for this option the last two years. +1. –  TeX HeX Aug 1 '11 at 16:25
    
@TeX HeX I just can't tell if he has any other issue based on the question, but I hope this does it for him...and you. –  KCotreau Aug 1 '11 at 16:28
    
@KCotreau - howdy, appreciate the reply but yeah... I did change all four dropdowns (and out of superstition tried changing just one or two, and mixing'n'matching). No matter what settings I choose, the formatting is retained. Drives me absolutely nuts. Why program in this option and have it simply not work? My only guess is somehow the copied text has a style definition from acrobat, and word retains the style even if it ignore specifics like bold, italic, font, etc. As a workaround, is there a plugin that always copies text as plain text from acrobat? –  CreeDorofl Aug 1 '11 at 21:07
add comment

Pasting "text only" from other programs does only seem to work in Word 2007, if the option "Show Paste Options Buttons" is selected. If this option is not selected, Word 2007 is ignoring the specification given for "Pasting from other programs". To me, this is clearly a bug.

share|improve this answer
add comment

Have you tried un-checking "Use smart cut and paste". It's the last option under the "Cut, copy, and paste" section.

I just did this and it seems to work (crossing fingers).

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.