Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

The question is, how do you delay AutoPlay in Windows 7? (Below is the reason and the scenario)

I am using DVD Fab 8.0.8.5 to decrypt movies (that I own) into the raw Video TS and Audio TS folders so that I can then convert them to mp4 files for streaming and mobile entertainment with my IPod.

I have DVD Fab set as the default program for DVDs in the Control Panel -> AutoPlay section (as seen below).

Screenshot

When AutoPlay tries to start DVD Fab, like it is supposed to, I get the following error.

enter image description here

I can then proceed to click "OK" in the pop up, start DVD Fab manually (Ugh... manual...), and everything works as it is supposed to. Is there anyway to delay AutoPlay? I think that is the issue, it is going too fast and cannot see the D:\ before it is recognized. If it is another issue, please tell me. I have Google-ed this for a while with no results.

share|improve this question
1  
From a security perspective, Autoplay is best left disabled entirely. But, I'm sure that's not what you wanted to hear. –  Iszi Aug 2 '11 at 1:29
3  
Does not make any sense to me, Autoplay starts when it recognizes the medium. At that point it has a path already.. –  soandos Aug 2 '11 at 2:04
    
I don't understand it either @soandos... –  David Aug 3 '11 at 15:13

1 Answer 1

I'm taking a bit of a stab in the dark here. Take this as guidance, not a solution.

Open the Registry Editor and navigate to:

\HKEY_CLASSES_ROOT\DVD\shell\play\command

Here is the command that executes DVD Fab when you insert a DVD. I'm assuming it resembles something like:

"C:\Program Files\DVDFab\DVDFab.exe" "%L"

The "%L" stands for "drive letter", in this case "D:". DVD Fab expects more details. Take a look at the DVD Fab Command Line reference. Try:

"C:\Program Files\DVDFab\DVDFab.exe" /MODE "FULLDISC" /SRC "%L\VIDEO_TS"
share|improve this answer
    
Thanks a lot for the great answer @Han-E-Food! +1, I will accept it if it works. Sorry I have not had enough time to check to see if this works yet. (I haven't even had time when at home to start that computer up... lol) –  David Aug 3 '11 at 15:19
    
This did not fix it unfortunately... But, I am still playing around with this idea and some of the tools you have given me. Thank you very much! –  David Aug 4 '11 at 20:30

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.