Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a 2 GB Micro SD card. It was working very fine before few months ago and when I changed the phone I got a new one with that so I didn't use my Old one for a while. But few days ago I need some old data from that card and I inserted it in my laptop and it is giving me error (As shown in picture).

enter image description here

enter image description here

I tried out this link but it couldn't help me.

share|improve this question
    
Are you inserting the microSD card using a phone cable or an SD card adapter? Also, have you tried inserting the microSD card on just one machine or multiple different machines? –  TookTheRook Aug 4 '11 at 14:27
    
Yes I have tried on different computers too and I'm trying to inserting it through SD card adapter. –  avirk Aug 4 '11 at 15:00
    
Let me know if it doesn't work even if you use the SD card adapter. Also, do you have your old phone? Does the microSD card still work with the old phone? –  TookTheRook Aug 4 '11 at 15:02
    
No now the phone is also not reading it that's a big problem if phone cud read I would copy the data on phone memory. –  avirk Aug 4 '11 at 15:04
    
I recommend only using brand name SD cards and USB flash drives. I've experienced a few failures (most not my own), but I've never seen a SanDisk fail. –  paradroid Aug 18 '12 at 11:29

3 Answers 3

PCInspector has a tool (Smart Recovery) that can recover data from memory cards. In my experience it works pretty well. It only searches for image files, though. If you're looking for other file types (ie, you use this SD card as a memory stick) PCInspector has another file recovery utility that has worked for me pretty well.

They are both free (as in beer).

share|improve this answer

It seems that the memory card may be corrupted. Follow the instructions here to recover data from your microSD card.

Basically, the article recommends to open the command prompt and run Chkdsk e: /r where e: is the name of the drive (so M: in your case) and /r tells it to repair the issues it finds with the card.

Good luck.

share|improve this answer
    
When I tried that I got an error that " The type of the file system is RAW. CHKDSK is not available for RAW files." Sounds like my card has completely dead. –  avirk Aug 4 '11 at 15:37

Even though this thread is three years old, I have decided to share my experience because it was at the top of my initial search results when I was having this same issue. I was able to get my pictures back.

In my case, it was a 4GB standard-size SD-Card. And it stopped working from one day to the next while remaining seated in my digital camera. The camera gave me the following two error messages (one on top of the other):

Memory card error

Card locked!

First I made sure that the card itself had a defect, not the filesystem, or the card reader in the camera, or whatever else it could conceivably be. I tried all of the following:

  • reading the card in the original camera
  • reading the card in several different card readers on my PC
  • running file -s /dev/sdg (designation of my card reader) with each card reader to make sure it was completely unresponsive
  • blowing through the card reader
  • carefully cleaning the card's contacts
  • sliding the lock switch back and forth
  • putting a piece of tape over the lock switch cutout to make sure the reader would see the card as unlocked

And when none of those things helped, I decided to look into professional data recovery options. I found a small company in Dresden, Germany, that specializes in Flash recovery: Recoverfab

Apparently, a common cause of SD Card deaths is a malfunctioning controller chip. What they do to get at the data is remove the storage chips from the card, and then read out the raw state of those chips into an imagefile. Then they sort that imagefile out into the bits and bytes that the controller would otherwise present to the card reader.

Of course I wasn't happy that my pictures would incur further costs, but I have to say their prices are very reasonable. I was quoted a price of 126€ to be paid only if recovery was successful, and after being able to review thumbnails of the images recovered.

And I am very happy to have my pictures back.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.