Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Is there any way, via about:config or otherwise, to prevent Firefox from closing when app tabs are open?

I'm using Firefox 5.0.1 and 8.0a1 nightly.

share|improve this question
    
I am really not sure what you mean. Please clarify. –  user606723 Aug 2 '11 at 15:22
    
@user606723 - I am exactly sure what Jags means. support.mozilla.com/en-US/kb/what-are-app-tabs –  Shinrai Aug 2 '11 at 15:23
    
Thanks. Didn't know about app tabs. Anyway, this functionality works for me by default. I should add that upgraded from firefox 3, and still have the firefox 3 look and feel and whatever firefox 3's defaults are. –  user606723 Aug 2 '11 at 16:05
    
It is a common problem, and I couldn't find any solution to this problem other than manually locking the app tabs or restoring app tabs sessions, but I suggest you take a look at this. I don't know why this bug is not being fixed, and why none of the tabs addons have an auto-lock app tabs option, but I am sure it's only a matter of time until it will be fixed. –  amiregelz Jul 19 '12 at 9:24

2 Answers 2

Browser.tabs.closeWindowWithLastTab set to false does it for me.

share|improve this answer
    
@ user606723 & Shinrai many thanks. What I meant, when I have 2 or more app-tabs open & if I accidentally close (red X at top right corner) Firefox, Firefox won't even display a warning that it usually displays when I have 2 or more regular tabs open and if I tries to close Firefox. What I would prefer (my personal 1st choice option) is that Firefox throw an error that first you need to close app-tab manually (right click on app-tab and click close) then you can close Firefox. My 2nd choice would be FF throw a warning that it displays while closing 2 or more regular tabs. Any workarounds? –  Jags FL Aug 2 '11 at 16:28

This seems to be a long standing issue with Firefox. One possible workaround is to use the Always Ask extension.

share|improve this answer
    
Not a perfect solution, but the best I've found. Thanks. –  Chance Jul 19 '12 at 22:45

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.