Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have an Acer Aspire 5738Z with a LITEON Slimtype DS8A3S. The firmware on it is HA17. It used to read everything excluding DL DVDs fine, but now it only reads CDs and blank DVDs. I've tried the following:

  • Using a lens cleaner. CDs now work faster, no luck with DVDs.
  • Flashing HA24 onto it. Didn't change anything, rolled back to my backup. Can't flash clean HA17 because I can't find it.
  • Using different operating systems - both Vista and Ubuntu 11.04 do the same things.
  • Using LtnRPC to change regions and disabling region protection.
  • Different DVDs (data DVDs, movie DVDs), including region-free.

This is weird because I haven't been using the drive much at all, and it stopped working randomly.

When I insert a DVD it spins for some time rapidly and then just stops. The OS indicates the drive is empty.

share|improve this question

Given what you've already tried, which is impressive, I think you're quite warranted to just replace the drive.

With a dash of luck, you're still within warranty time(?). If not, maybe consider an external one - I've seen some decent little USB-powered ones that were like ~$40. If you're in the states, I'd go to Fry's or NewEgg for such a drive. If you're in Canada, check out MemoryExpress.

Nice debugging effort. Good luck.

share|improve this answer
    
Well, I was pretty much looking for a solution that doesn't involve hardware replacements... – nickguletskii Aug 2 '11 at 18:34
    
Understandable - but it sounds like a hardware fault. – Doc Aug 2 '11 at 20:20

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .