Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

We're using remote desktop to connect to a remote machine running windows 7. The problem is, that when one user is logged on, the others have no way (AFAIK) of knowing it. Thus, when a second user logs on, the first user gets kicked out without a warning.

Is there a way to prevent this? Please note that:

  1. The machines are not on the same network
  2. We are not interested in concurrent sessions (e.g. using a patched termsrv.dll).
  3. Both source and target machines run Windows 7 Ultimate

EDIT

I was thinking about something like Tight-VNC's behavior, where if two users can log on simultaneously with the same username. In this case, keystrokes and mouse movements made by one, are seen by the other.

share|improve this question
    
Is RDP a requirement or can you switch to some other app/protocol as long as the functionality is equivalent? –  Shinrai Aug 2 '11 at 19:09
    
Are you using the same account to log on with? –  KCotreau Aug 2 '11 at 19:19
    
If you aren't using a server edition, then this is impossible. –  surfasb Aug 2 '11 at 20:53

1 Answer 1

I may delete this based on your answer, but if you are using the same username, it will assume you don't mind kicking yourself off, but it will ask both sides if they want to do it if they are different users.

I tested with a standard user currently logged in, and an administrator connecting to make sure it would still ask.

  1. Screenshot one: "Another user is currently logged on to this computer. If you continue, this user has to be disconnected from this computer. Do you want to continue?"
  2. Screenshot two: I clicked yes above, and it says "Please wait for KCotreau-PC\Test (the name of the standard user) to respond".
  3. Screenshot three: This is of the screen of the computer being remoted into, and it gives the user, KCotreau-PC\Test, the option to disconnect immediately, do nothing and it will happen anyway in 30 seconds, or to cancel and not allow the incoming connection.

If you are the same user logged in and RDP'ing, it just does it.

So if you are both using the same user, just set up two different ones, and it should work as you want. Otherwise, I am not sure how else to do it.

enter image description here

enter image description here

enter image description here

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.