Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have Creative Vista Webcam (041e:405f) which has very slick and nice design but it doesn't really work under Ubuntu, all I can see is a green screen with some noise. How can I make it work?

alt text

share|improve this question
add comment

3 Answers

up vote 3 down vote accepted

Ubuntu Karmic Koala (9.10)

Just recently I found a way to make it work with Ubuntu Karmic Koala. Solution for Jaunty will not work since ov51x-jpeg driver can't be compiled with new kernels but luckily we don't need it anymore. So if you have followed tutorial for old ubuntu, make sure you have deleted any entries from blacklist you might have made. If you have followed my tutorial, this means you have to delete /etc/modprobe.d/creative_vista.conf file

rm -f /etc/modprobe.d/creative_vista.conf

So, in order to make this camera to work with skype, all we have to do is to start skype in a special way

sh -c 'export XLIB_SKIP_ARGB_VISUALS=1 && LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so /usr/bin/skype'

I'm sure you don't want to start it like that every time, so right-click on 'Applications' menu, select 'Edit menus'.

enter image description here

Then find Skype there and change it's 'Command' to the line above. Don't forget to click 'Close'.

enter image description here

That's it, camera will work.

reference: ubuntu forums

Ubuntu Jaunty (9.04)

This is how I made it under Ubuntu Jaunty (9.04). All the tutorials out there are outdated and wants you to use gsfakevideo or patched ov51x-jpeg driver. Nothing of that is necessary.

So first of all make sure it is right webcam.

$lsusb
Bus 003 Device 004: ID 041e:405f Creative Technology, Ltd

check that ID is 041e:405f here.

Now here's the fact, this webcam works with ov51x-jpeg driver but Ubuntu tries to use gspca_ov519 module for it.

First, check that you have module-assistant and it works:

$ sudo aptitude install module-assistant
$ sudo m-a prepare

Then we have to install ov51x-jpeg module:

$ sudo m-a a-i ov51x-jpeg

This little command will download all the packages it needs, compile our module and install it. No need to do that manually.

Then we have to check if it works.

$ sudo rmmod gspca_ov519
$ sudo modprobe ov51x-jpeg forceblock=1

Open your favourite application with video (I used skype 2.1 beta) and check if you have a picture.

Now you have to make sure it all will work after reboot.

$ echo 'blacklist gspca_ov519' | sudo tee /etc/modprobe.d/creative_vista.conf
$ echo 'options ov51x-jpeg forceblock=1' | sudo tee -a /etc/modprobe.d/creative_vista.conf

Note: this will disable gspca_ov519 driver completely, so if you ever will change webcam, make sure you delete /etc/modprobe.d/creative_vista.conf file.

Now restart your computer and check if it works.

share|improve this answer
add comment

This no longer works with Karmic Koala and I'm not sure how to get around it :(

% uname -srvm 
Linux 2.6.31-14-generic #48-Ubuntu SMP Fri Oct 16 14:05:01 UTC 2009 x86_64

$ sudo m-a a-i ov51x-jpeg

Build of the package ov51x-jpeg-source failed!

/usr/src/modules/ov51x-jpeg/ov51x-jpeg-core.c:6386: error: too many arguments
 to function ‘video_usercopy’
/usr/src/modules/ov51x-jpeg/ov51x-jpeg-core.c: At top level:
/usr/src/modules/ov51x-jpeg/ov51x-jpeg-core.c:6651: warning: initialization
 from incompatible pointer type 
make[4]: *** [/usr/src/modules/ov51x-jpeg/ov51x-jpeg-core.o] Error 1
make[3]: *** [_module_/usr/src/modules/ov51x-jpeg] Error 2 
make[3]: Leaving directory `/usr/src/linux-headers-2.6.31-14-generic'
make[2]: *** [all] Error 2 
make[2]: Leaving directory `/usr/src/modules/ov51x-jpeg'
make[1]: *** [binary-modules] Error 2 
make[1]: Leaving directory `/usr/src/modules/ov51x-jpeg'
make: *** [kdist_build] Error 2
share|improve this answer
    
It should have worked out of the box on Ubuntu Karmic or so I though. We'll try myself and get back to you later. –  vava Nov 18 '09 at 1:26
    
Ok, it doesn't work for Karmic Koala yet and I don't know when it will. Yet another thing that get broken in 9.10. –  vava Nov 18 '09 at 2:22
    
I found a way to make camera work and updated my answer –  vava Jan 30 '10 at 8:33
add comment

http://www.rastageeks.org/ov51x-jpeg/index.php/Main_Page

You have to patch ov51x-jpeg sources with patches for 2.6.30, then you can use:

m-a a-i -O ov51x-jpeg

The -O switch disables downloading the ov51x-jpeg source again. So the whole sequence is:

  • m-a get ov51x-jpeg
  • patch sources in /usr/src/modules/ov51x-jpeg with these patches (I don't remember correct order)
    • kernel_messages.patch
    • ov51x-jpeg-2.6.29.patch
    • ov51x-jpeg-2.6.30.patch
    • noowner.patch
  • m-a a-i -O ov51x-jpeg

This worked on my debian/testing and kernels 2.6.30,2.6.31 and 2.6.32.

share|improve this answer
    
Luckily you don't really have to do that as this camera works out of the box now :) Well, you still have to do some workarounds for Skype but you shouldn't care about ov51x-jpeg driver. –  vava Mar 8 '10 at 4:31
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.