Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

We built and captured a sysprepped image of a computer that we had installed Windows XP on using the Windows XP SP3 media and have been using it for months without issue. Suddenly, some time this morning, on all computers we build using this image, the Windows Update website (http://windowsupdate.microsoft.com) redirects to the KB article page for KB2497281

Reinstalling SP3 fixes it.

What is causing this problem? How can I run Windows Updates without having to reinstall SP3?


Moderator note: this question is getting many views and answers in a short time span.
If you have the same problem, we hope that the answers here can help you, but please do not post an answer unless you are suggesting a solution. Answers that say "me too" or are in response to other answers will be removed. If you do have a solution and would like to provide an answer, please read the FAQ and How To Answer first. Thanks!

share|improve this question
    
I know this seems silly, but are you super extra totally certain that you have SP3 on those computers? If you run winver from the run dialog, it says Windows XP SP3? –  nhinkle Aug 3 '11 at 17:57
    
@nhinkle - see my answer. I saw this problem last week on a new image of XP SP3. –  user3463 Aug 3 '11 at 17:59
    
I confirmed by right-clicking My Computer and clicking Properties. To be 100% sure, I just used your method (winvir) and it also confirms SP3 is installed. –  Chck Aug 3 '11 at 17:59
    
Chck thanks for double checking. I figured you were probably right, but it never hurts to look. @RandolphWest thanks for the info, hopefully that'll solve the problem. –  nhinkle Aug 3 '11 at 18:01
2  
I was able to resolve this by downloading and installing the latest version of the Windows Update Agent here: support.microsoft.com/kb/949104. I have a < 100 reputation, so I can't self-answer for 8 hours after posting the question. I will self-answer later. –  Chck Aug 3 '11 at 18:45
show 2 more comments

3 Answers

This solution worked for me:

  1. Open Command Prompt: Start -> Run... -> cmd -> OK
  2. Stop Automatic Updates Service: net stop wuauserv
  3. Register wups2.dll: regsvr32 %windir%\system32\wups2.dll
  4. Start Automatic Updates Service: net start wuauserv

Source: http://support.microsoft.com/kb/949104

share|improve this answer
    
I tried to install Windows Update Agent at first, but I wasn't able. –  Klemen Košir Aug 3 '11 at 20:15
add comment

I managed to get past this problem twice by setting Automatic Updates to Notify Only, waiting a few minutes, then running Windows Update normally.

On edit: Machines were fresh SP3 installations and manual SP3 & IE8 install failed to fix the issue.

share|improve this answer
    
Built three more machines today. The Notify Only method bypassed the problem on all. The wups2.dll did not exist in the system32 directory, so the regsvr32 method would not work. Additional info: these are all XPHome with Automatic Updates disabled during the install. –  yowza Aug 4 '11 at 18:56
    
Three more today, all XP Pro. All exhibited the problem. Windows Update Agent worked, tho took longer than enabling Notify Only. The wups2.dll file did not exist in the System32 directory. –  yowza Aug 5 '11 at 21:57
add comment

When I had this problem last week on a new build, I installed IE8 and the problem went away.

share|improve this answer
    
I just installed IE8, and this did not resolve the issue. Thanks for the suggestion, though. –  Chck Aug 3 '11 at 18:20
add comment

protected by random Aug 4 '11 at 1:51

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.