Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm relatively new to iOS development with Xcode4, but when I started using it it seemed like the default setting for the split view was to display the file you were editing in the left pane, and then a related file in the right pane, the .h if you're editing a .m, the .m if you're editing a .h, or the .h if you're editing a nib. (I'm not actually sure quite what the correct terminology is for the view, I'm talking about the view you get when you click the little gas-mask looking button, the middle one of the three above the word "Editor" in the top toolbar.)

Anyway, sporadically this syncing breaks, and the two panes will just show whatever file they happened to have last, without updating when the other pane updates. I don't know what this behavior is called so I don't know how to find the option to change it, or what I might be doing to make it sporadically break. I don't know if this is a bug or if I'm just accidentally hitting an obscure keyboard shortcut.

share|improve this question
add comment

1 Answer 1

up vote 0 down vote accepted

Well, figured this one out. When you enable the assistant pane there's a toolbar at the top of the pane with buttons corresponding to a partial file path of whatever file you're currently working on. The leftmost button, right next to the left and right pointing black arrows, says "Manual". You can click on that to pop up a menu that lets you pick from several different options, among which is Counterparts, which will give you as its sole suboption the file that actually corresponds to what you're working on in the main pane.

The way I figured this out was restarting my computer and noticing that when I restarted xcode, all of my windows were gone, and once I went to the view menu to reenable all of them that setting was back to "Counterparts" from "Manual". So I don't know what the hell is going on with xcode changing settings on me. But that solves that one problem.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.