Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My Time Machine backs up to a hard drive connected to my Airport Extreme. After I've upgraded to Lion I have noticed that the mds process (the Spotlight indexer) has been running at 100% cpu every now and then. A simple file activity check told me that it was trying to index my Time Machine backup.

I have gone and added the Time Machine disk to the Privacy list in Spotlight settings, which is supposed to exclude the disk from the Spotlight index, but alas, Spotlight still tries to index it sometimes. Is it a bug in Lion or am I missing something?

share|improve this question
    
Maybe you want to clear the Spotlight index and restart and see if that resolves the issue (first comment below the post is also useful). –  slhck Aug 4 '11 at 22:44

3 Answers 3

up vote 5 down vote accepted

There is a command line option Wheat;

$ mdutil 
Usage: mdutil -pEsa -i (on|off) -d volume ...
    Utility to manage Spotlight indexes.
    -p             Publish metadata.
    -i (on|off)    Turn indexing on or off.
    -d             Disable Spotlight activity for volume (re-enable using -i on).
    -E             Erase and rebuild index.
    -s             Print indexing status.
    -a             Apply command to all volumes.
    -V vol         Apply command to all stores on the specified volume.
    -v             Display verbose information.
NOTE: Run as owner for network homes, otherwise run as root

So on the Mac you need to:

$you@yourmac: mdutil -d /Volumes/YOURDRIVE [enter]
$you@yourmac: mdutil -E /Volumes/YOURDRIVE [enter]

Then you need to reboot (it seems that indexing does not stop until the Mac has been rebooted in some cases). The first line will disable the indexing, the second line should delete all of the index for that drive.

share|improve this answer
    
I have noticed that the Macs sometimes ignore the .metadata_never_index magic file which is a shame as it would be a very useful way to block it. I think the system gets confused about what is a root directory of what so network drives don't get excluded. I have seen unix home directories taking a hammering because the system would not stop indexing even if the magic file was there before the directory was automouted. –  TafT Dec 21 '12 at 10:49

Do the following terminal actions:

$you@yourmac: cd /Volumes/YOURDRIVE [enter]
$you@yourmac: touch .metadata_never_index [enter]

If you want to remove the existing Spotlight indexes, do this, carefully otherwise you may remove important other stuff:

$you@yourmac: cd /Volumes/YOURDRIVE [enter]
$you@yourmac: rm -rf .Spotlight-V100/ [enter]

Done. No more overkilling your external drives. Works both on Snow Leopard and Lion.

share|improve this answer

The commercial utility MacPilot from Koingo Software can be used to completely delete the Spotlight index database and force Spotlight to create a new one. This is a maintenance step that I find myself needing to perform from time to time.

There must be a command-line procedure for doing this without needing MacPilot. Perhaps someone else can post about that here.

share|improve this answer
    
MacPilot did the trick - allowed me to add the remote directories to spotlight (which was not happening through traditional means). Not much of a terminal guy and MacPilot did the trick! Thank you. –  user125007 Mar 27 '12 at 12:57

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.