Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Edit: Problem 1 has been resolved.

I followed this link and changed my user id to 1000 (same as Linux user id), so that I can share files freely between Mac and Linux. Now I have these two problems:

  1. I am not able to empty trash. I have checked file permissions in the trash and they belong to my current user. Even the files themselves were located in a local disk, not an external disk before deletion.
  2. Login window doesn't list users, it just shows 2 fields one for username and another for password. I checked Login Options under "Users and Groups" in the System Preferences, and it is set to "Display login window as List of users".

How can I fix this?

share|improve this question
Have you rename /.Trashes/{old UID} to /.Trashes/{new UID} ? Have you changed the permission ? – Raptor Aug 4 '11 at 3:26
There is no {old UID} in the /.Trashes folder. and the permissions look like this: drwx-wx-wt@ – Baha Aug 4 '11 at 3:38
there was a ~/.trash folder, and deleting it emptied the trash. – Baha Aug 4 '11 at 3:45
up vote 1 down vote accepted

While it's well known that the login window hides all user accounts with ids below 500, it seems the user ID 1000 is also hidden:

The next option is to set the user's ID to 1000. In OS X, an account with UID 1000 will not show at the log-in window, so you can select one to use and set its ID so it will not display. To do this, go to the Users & Groups system preferences, authenticate, and then right-click an account to select the advanced options. In here, you should see a set of fields with some details about the account, such as its home folder, name aliases, and its UID. Simply change the UID value for the account to 1000, apply the changes, and the account should no longer show up at the log-in screen.

Your only way out of this is probably to adjust your Linux to the Mac user IDs, or change both systems to e.g. 1001.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.