Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a strange issue with a Kodak printer that is set up on an Small Business 2008 server, and shared out. The printer prints fine from all Windows XP stations, but won't print from the only Windows 7 32bit (there are no 64bit stations onsite) station that they have on site.

The print driver is fully up to date as per Kodak's website, and the printer firmware is up to date as well. The printer is advertised as Windows 7 compatible.

The issue is as follows: The printer installs fine from the share, accepts the driver with no issues, and the Kodak AIO software recognises the printer. I can print a test page from the Kodak AIO software, but as soon as I try to print from Windows the print job doesn't reach the printer and I receive the following error in the event log:

Application error:

  • Faulting application name: PrintIsolationHost.exe version 6.1.7600.16835
  • Faulting module name: KERNELBASE.dll, version 6.1.7601.17625
  • Exception code: 0x80000003
  • Fault offset: 0x00033e2e
  • Faulting process id: 0x1024

I have attempted a reinstallation of the printer on both the server and the client PC.

share|improve this question
    
Install the Kodak W7 driver manually on the W7 pc, I think it is using the wrong driver. –  Moab Aug 4 '11 at 16:46

2 Answers 2

up vote 1 down vote accepted

Install the Kodak W7 driver manually on the W7 pc, I think it is using the wrong driver.

If this fails to get it printing, perform a clean boot in Windows 7 and try printing. If this solves it you have a startup program or Non Microsoft Service causing the issue.

To Boot Clean in Windows 7 and Vista

Accessing the System Configuration Utility

  1. Click Start type msconfig in the search box and press Enter

Configure Selective Startup options

  1. On the General tab, choose Selective Startup
  2. Uncheck Load Startup Items
  3. Select the Services tab
  4. Check Hide all Microsoft services
  5. Click Disable all
  6. Click on OK
  7. Click Restart.

After performing the necessary steps, restore your system to normal boot by doing the following:

  1. Click Start type msconfig in the search box and press Enter
  2. On the General tab, choose Normal Startup
  3. Click Ok
  4. Click Yes, when asked to restart your computer
share|improve this answer
    
Hi, thanks for the response. Unfortunately this has not fixed the issue. –  user70885 Aug 5 '11 at 12:31
    
Which, upgrading the driver or clean boot diagnosis? –  Moab Aug 5 '11 at 15:27
    
Sorry about the lack of reply. We tried both and Kodak has no answers. Returning the printer as it gives no end of issues. –  user70885 Aug 9 '11 at 10:39

I have the Kodak ESP 5250. It would print test page from Kodak Home application but would not print from any other applications. Kodak sent me a list of things to try and none of them worked but I finally found something that worked!

If you are having a similar problem, try this:

  1. Go to: Devices and Printers > **Advanced Tab

  2. Choose Print Processor.

  3. Choose Winprint.

  4. Choose Raw.

  5. Click the Ok button.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.