Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Regarding browser mode, IE8/9 is supposed to be configured by default to:

  1. Render all intranet pages in compatibility mode (falling back to either IE7 "standards mode" or IE5.5 "quirks mode" rendering dependeing on whether or not there is DOCTYPE declared)
  2. Automatically identify intranet urls to decide when to fallback

These settings can be configured in:

  1. Tools > Compatibility View Settings > "Display intranet sites in Compatibility View" -checkbox
  2. Tools > Internet Options > Security -tab > Local intranet > Sites -button. Under popup there are checkboxes to configure the automatic resolution.

In my browser, the "Display intranet sites in Compatibility View" -checkbox is disabled and I cannot turn it on. Why is it disabled and how can I turn it on? By disabled I mean the checkbox is grayed out, so it cannot be enabled.

share|improve this question
    
If this is a work computer it may be set by your company's IT staff via group policies. –  Ƭᴇcʜιᴇ007 Aug 4 '11 at 13:52
    
I thought about that, but disabling just one checkbox feels too detailed to be possible. Might be that though if you know it's possible. I filed a ticket to our IT support about the issue. Any other suggestions of course welcome :) –  Tuukka Mustonen Aug 4 '11 at 13:56
add comment

2 Answers 2

up vote 2 down vote accepted

If this is a work computer it may be set by your company's IT staff via group policies.

"There are approximately 1300 Group Policies for managing Windows® Internet Explorer® 8" including settings for "Turn off Compatibility View", and "Turn on Internet Explorer Standards Mode for Local Intranet".

You could probably determine which registry entry this policy sets, and if you have permission change it on your computer via RegEdit. But, if it is controlled by GP it will get reset the next time the group policy refreshes (about once an hour).

share|improve this answer
    
If you're on a work computer IE settings are probably controlled. Therefore this is probably the issue. –  music2myear Aug 4 '11 at 14:08
    
That was it. Quite a number of settings they can control, never realized you can fine tune in this detail. Thanks for the pointers! –  Tuukka Mustonen Aug 5 '11 at 8:01
add comment

Even though techie007's answer sets you on the right track, I still had to do some research.

Based on the URL he provided (and I did this for IE10, so it most likely applies to any version above 8), what I did was:

1. Windows Key + R 
2. type: gpedit.msc and hit enter
3. Expand and navigate to: Local Computer Policy -> Computer Configuration -> Administrative Templates -> Windows Components -> Internet Explorer
4. Double click on Compatibility View
5. Right click on "Turn on Internet Explorer Standards Mode for local intranet".
6. Set it to "Disabled".

This will uncheck the checkbox, but it still remains disabled. I haven't found a way to control the checkbox state yet, but this at least allows you to control whether it is checked or not.

It would look like this:

enter image description here

share|improve this answer
    
thanks, man! Learnt something new today! –  S.M. Al Mamun Mar 5 at 2:03
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.