Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a custom build PC:

  • Corsair HX620 PSU
  • Intel 6870 C2D
  • Geforce 8800GT
  • Asus P5Q-E

I've recently moved from the UK to Canada, upon plugging my UK built PC into the wall socket it gets stuck in an infinite loop of booting and rebooting, the fans spin, internal and external LED's light, but no output to the monitor.

My HX620 apparently will auto select the right voltage, but I can't rule regional issues out, I am using brand new Canadian plugs, straight into the wall socket.

Tried the following:

  • Reseat graphics card - No effect
  • Remove and replace battery from motherboard - No effect
  • Disconnect HDD - No effect
  • Disconnect Graphics Card - No effect
  • Disconnect CD-ROM - No effect
  • Reseat RAM modules - No effect
  • Remove 3 RAM modules - No effect
  • Swap remaining RAM module with one of the 3 removed - No effect.
share|improve this question
Do you have a speaker/buzzer connected to the appropriate header on the motherboard to hear any warning beeps? If your motherboard has voice error reporting, have you tried connecting headphones or speakers? – washbow Mar 7 '13 at 20:53

If things look OK physically (ie: heatsinks, etc.) then if you remove your RAM, and you get no POST beeps telling you you have no RAM, your motherboard or PSU is probably broken/malfunctioning.

Amongst what others have suggested, you can try:

  • Try a different wall socket, and if you have one, a different mains cable.

  • Determine if on-board power-good LED is staying lit steady during these power cycles, if it's turning on and off with the power cycles, then it's probably the power supply.

  • Reseat (unplug and replug) all your power taps. I see that PSU has modular plugs, so do it to both ends. Triple check that the 24-pin ATX cable is 'clicked in' all the way.

  • Unplug all drives, take out everything except the CPU, RAM and Video. If it works, then start plugging stuff back in one at a time until you find the culprit.

  • If it still doesn't work, then the next thing to try is a known-good power supply. You may want to try this before the previous suggestion if you have one kicking around. :)

  • If that doesn't fix it, it's more than likely a busted motherboard.

share|improve this answer

Only things I can think of is that the auto select for voltage didn't work and it has fried itself (the PSU) or the PC got knocked about a bit in transit.

Try opening the case and re-seating everything first. If that doesn't do the trick I'd try buying a new PSU.

share|improve this answer
I packed the entire case solid with bubble wrap before I shipped it, hopefully the auto select did work, there wasn't any fire anyway! – JuniorDeveloper1208 Aug 5 '11 at 1:03

There would be 3 problem until I know:

1 - Processor: Check if your processor is well fit on socket and the cooler is also collecting processor's heating.

2 - Memmory: Check if your memmory sticks are well fit on them sockets.

3 - Video Card: Check if your VGA is well fit on your PCI-Express socket.

If after checking all of this itens and nothing happends so maybe would be another hardware problem that you can only verify by changing items (processor, memmories, VGA or even the motherboard).

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .