Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have installed 2 linux distributions, Fedora 15 and Ubuntu 11.04. I have a partition formated in ext4 filesystem and i mounted using the /etc/fstab file on /mnt/files/ mountpoint. It mounts correctly in both distros but i have one problem with permissions. This exapmple illustrates it:

If i create a folder /mnt/files/test/ using mkdir in this common partition from Ubuntu, when im on Fedora and try to create a directory inside this folder, say /mnt/files/test/test2 it says that i dont have the permissions. I have read som solutions, and the most of them says that i have to change the permissions or the owning of the folders using recursively chmod or chown but the problem is that i have to do this every time that i create a new file or folder on the other distro.

I want to know if is there any option on the fstab file that help me to achieve this. I have tried the uid, gid and umask options but it looks like this options cant be used on a ext filesystem.

The entry en my /etc/fstab file is:

UUID=<uuid> /mnt/files ext4 defaults 0 0

I hope you can help me.

Regards.

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

Your /etc/fstab really doesn't have anything to do with this.

You major problem is most likely that the UID/GID associated with your account on the two installations are different.

You can either

  • Setup groups using identical GIDs on both installations, and setup your permissions to be based on a common group
  • Adjust the UID/GID of one of the accounts so they are identical between your two installs.

To confirm that the two are different look at your account and primary group in the /etc/passwd, and /etc/group files of the two systems.

share|improve this answer
    
Thanks, it worked almost perfectly. Now when gnome ask my user it only shows the "other" option and not my full name. You know how to fix it? –  Marco Antonio Aug 5 '11 at 8:27
1  
I fixed it editing the /etc/gdm/custom.conf in the [greeter]section adding the option Include=<user> –  Marco Antonio Aug 7 '11 at 7:54
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.