Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Allow me to explain by showing you this picture:

My Taskbar

As you can see, it is a picture of my Windows 7 taskbar, no modifications made.

Now let's take a look at the right 3 active Icons. You have Navicat (the greenish icon) running, note that it has 2 windows open. Next is Notepad, I've opened 3 instances of notepad as you can see, it's grouped together.

Now for my last one, NetBeans (the blue cube). Only this time, after opening NetBeans by clicking on the taskbar shortcut. It opens NEXT to the icon, instead of merging with it like we've seen with navicat and notepad. If I click the left one (the shortcut) it simply opens the already running NetBeans, and if I click the right one (the active instance) it behaves exactly the same, it simply opens up the already running instance.

Why is this application not merging with the taskbar? How can I let it Merge? And why doesn't it let me open up multiple instances of NetBeans when I click the shortcut? Please provide me with a way to at least solve the merging problem, as a perfectionist I can't sleep at night because of this brutal flaw within the taskbar.

PS: I already tried middle-clicking the icon to open up a new instance but it's not working.

share|improve this question
    
Thanks slhck for putting in the image –  Pieter888 Aug 5 '11 at 8:28
add comment

2 Answers 2

up vote 2 down vote accepted

The left one (of the two Netbeans icons) is pinned, yes? Try running the program, unpinning the left one and pinning the right one. Or just unpin whatever is currently there, then run the program and pin the icon that pops up.

I've had it happen to me before, but pinning the running application works more reliably for avoiding this than pinning any shortcuts, etc.

However, it turns out this is a known bug with NetBeans when using 64-bit Windows and 64-bit Java to do with the 32-bit exe being unable to load the Java elements itself and having to launch a new process. It has yet to be fixed.

As a work around, you could:

  • another question poses a similar problem, and has an answer that suggests installing the SevenBeans module for NetBeans that solves this problem as part of it's other functionality.

  • modify the NetBeans shortcut that is pinned with the command line option --jdkhome "C:\Program Files(x86)\Java\jdk", to force it to use the 32-bit Java interpreter.

  • setup a new shortcut to run the 64-bit javaw.exe with the relevant parameters to run NetBeans, and pin that instead.


As for running multiple instances of NetBeans, you can only do so if each instances is using a different userdir (as per their FAQ), which you can do by using the --userdir <path> command line option, either from cmd directly or from preconfigured shortcuts.

share|improve this answer
    
This worked perfectly! I installed the SevenBeans plugin, and then followed your steps to unpin the in-active one and pin the new one. Thanks for the help! –  Pieter888 Aug 5 '11 at 9:44
add comment

Generally, the icons are linked to a .exe. If you are running a program that starts a launcher to the correct .exe, the launcher will open, launch the program, the then launcher will close. The icon for the launcher and the program are the same in many cases. This is probably your issue.

share|improve this answer
    
It seems to be launching the right application, though the launcher might simply have the same name as the actual application. I there anyway to check this? –  Pieter888 Aug 5 '11 at 8:28
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.