Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a fileserver in my network, with the storage accessible via NFS.

From one particular client machine, reading from this NFS share is really slow. Or rather, it stops all the time. The pattern goes like:

  1. Copy really fast for like 2 seconds
  2. Stop for approximately 18 seconds with no bits transferred (this is what I want to get rid of)
  3. Repeat from 1.

It is not the server: I can access NFS quickly from several other machines in the network.

It is not the network: See above. The one problematic machine is connected with a cable, so it's all good.

It is not the hardware in the problematic machine: I had Ubuntu 11.04 x86 installed, and then NFS worked well. The problem has appeared after I installed Ubuntu 11.04 x86-64. (I don't know what causes it, but as I say; it worked before. Now it doesn't)

It is not the mount options: I copied the relevant line in fstab from the x86-installation. I have also tried altering the mount options to no avail.

I can't see anything relevant-looking in dmesg or syslog.

I don't really know how to continue debugging this. What can cause nfs to behave like this? What tools can I use to determine what is causing the lock/stop? Help? :)

share|improve this question
up vote 0 down vote accepted

It was the network after all. I had stretched and bent the freaking network cable in such a way that the autonegotiation made the network speed 10Mb/s, half duplex. This I discovered with ethtool eth0.

The apparent stops I think must have been due to some buffering somewhere. When I looked closer it appeard that the copying was just really slow. I looked closer by enabling nfs logging to syslog with sudo sysctl -w sunrpc.nfs_debug=1023.

How about that?

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .