Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

On my drive I had 2 partitions for an Ubuntu 9.04 (swap, /) and one partition for Windows. I figured out that I should upgrade my Ubuntu, so I deleted the "/" partition and in its place created 2 new partitions (/, /home) .

After installing the latest Ubuntu 11.04, I realised that although I had backuped everything I needed in a 2nd disk and I could access those folders and their data from my Ubuntu 9.04, both my Windows and the 11.04 can locate neither the folders nor the data now. I have no idea why this happened (perhaps some issue with the mounting?)

I have tried the trial version of Stellar Phoenix linux data recovery tool, but it cannot locate the old partitions.

Since some of the files I lost are very important for me, I would be very grateful if you could help me.

share|improve this question
So you made your new / and /home partitions on top of the old / partition? If so I am pretty sure most of your old data have been over-written. You should try recovering the data from your second disk. – Aug 5 '11 at 19:40
Right, the / and /home are over the old / , but it is a new installation ( the /home has nothing in it) so I was thinking that the old data could be recovered. As for the second disk, there is no clue where those files went. Could there have gone anything wrong during the (auto) unmounting of the disk? Any idea on what/how to search? – Harry Aug 5 '11 at 20:08
I've seen recoveries happen off of partitions that had been reformated and over written with data 2 or 3 times, so I wouldn't worry about that. I can't imagine that something went wrong while unmounting the disk. – Mike Keller Aug 5 '11 at 20:44
up vote 1 down vote accepted

Finally what I did was to use photorec to get all the data I could ( it returned a huge number of txt data files, something like 1.7 million, that summed up to almost 700 GB ) and then used grep (hours of grep-ing in fact) to search for the files I needed. Luckily it was only code I looked for, so I could find it in those txt's. If it was something else (video, audio, pdf) I don't know what I would have done. In the txt's that I recovered, the files I wanted would be found in many different chunks. Some of them were broken in parts, some of them were older versions. So be very careful on what you recover.

share|improve this answer

Try running TestDisk from a liveCD distro. I recommend SystemRescueCD which is handy to have around for all sorts of issues.

share|improve this answer
I have tried to use that but to no solution. Maybe I don't know how to properly use this, but the result of the analysis doesn't provide any clue (no "OLD" partition). What I am trying now is to use the photorec but it returns pieces of txt files that are pretty hard to manage and put to together. – Harry Aug 5 '11 at 17:18
That seems odd that it isn't recognizing the old partition at all. So I can understand better. Your two partitions the Windows and the Ubuntu 11.04 are on the same disk that the Ubuntu 9.04 was on? Have you formatted the disk multiple times or just the once when installing the new partitions over the old? Lastly, the partition that the data was on was it ext4 or a different format? – Mike Keller Aug 5 '11 at 17:23
The disk had 3 partitions (ext4, swap, ntfs). I formatted the ext4 only once (can't remember formatting it again except for the first time) and split it into two new partitions (ext4 both) – Harry Aug 5 '11 at 20:06
I did some checking to see if there were any issues out there about ext4 and couldn't find anything. I'm at a loss actually if TestDisk isn't locating the partition at all after the analysis. Sorry. bummed – Mike Keller Aug 5 '11 at 20:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .