Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I want to install emesene2 on Debian Squeeze, but it shows some dependency problemes like Python, which needs >=2.6.6-7 and python-papyon0.5.

I installed Python 2.7 and used update-alternatives to use Python 2.7 intead of 2.6. When I test python --version I got Python 2.7.2+, but when I run dpkg -i python-papyon_0.5.5-2_all.deb I am told that the system is still using Python 2.6.

 python-papyon depends on python (>= 2.6.6-7~); however:
 Version of python on system is 2.6.6-3+squeeze6.

How can I solve this issue?

share|improve this question

migrated from stackoverflow.com Aug 5 '11 at 15:55

This question came from our site for professional and enthusiast programmers.

1 Answer 1

Always avoid taking any action to change system-wide default Python version. Rather wait until the distro changes to that version, and you won't have to do anything other than keeping your system updated. If you want to use a specific version, simply call it directly, e.g.:

python2.7 script.py

Here's one other guy who got into trouble for trying to change the default.

How can I solve this issue?

Your issue is a little different from the warning above. It's a dependency issue that should have been fixed by using APT. Why are you using dpkg? Your system is also not up-to-date. You would not have received this error if it was. Since you are running Squeeze, do:

sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.