Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

A family member brought me their Dell Inspiron 1545 a few hours ago (I'm a software engineer so I know how to fix any and all computer issues, right??). They just bought a new battery for it that won't charge. After exhausting my Google-foo, I see three possible solutions:

  1. Bad motherboard (I don't think this is the case).
  2. Bad battery.
  3. Bad charger.

I'm thinking that #3 is the most likely because they are using a generic power supply. If everyone is agreed, or at least leaning in that direction, is there anyway to bypass this "feature" of Dells?

Any help is appreciated!

share|improve this question
You know you are allowed to say "no" to family, right? :) – Ƭᴇcʜιᴇ007 Aug 6 '11 at 1:44
you can test the power transformer with a volt meter to ensure it's working to narrow the issues. – Nick May 24 '12 at 1:38
up vote 1 down vote accepted

Dell notebooks are notorious for not charging batteries with adapters that aren't branded Dell. Your best bet is to order an adapter straight from Dell, or a Dell specific adapter from eBay or a local computer store.

I did retail computer repair for three years, servicing approximately 5 Dell notebooks per day, 5 days a week. We had universal AC adapters with tips to fit that would provide power to turn on the notebooks, but only the Dell branded adapters would charge the battery.

I don't know why this would be the case, but it was.

share|improve this answer
After extensive Googling, I believe that the charger was indeed at fault. – James Hill Aug 15 '11 at 15:12

Try this:

Disconnect AC


Remove battery

Connect AC


Open Device Manager

Click the plus (+) sign next to Batteries category, right-click all of the "Microsoft ACPI Compliant Control Method Battery" listings, and select Uninstall In the "Confirm Device Uninstall" dialog box, click OK. (it’s ok if you only have 1 of these).

Click the plus (+) sign next to System Devices. Right-click the “ACPI Fixed Features Button" and select Uninstall. In the "Confirm Device Uninstall" dialog box, click OK.


Disconnect AC

Insert battery

Connect AC


share|improve this answer
Thanks for the suggestion. I actually tried this already, just not with all the shutdowns as you described (I did attempt it your way as well). Still no dice. FYI - I did not have "ACPI Fixed Features Button" under System Devices. – James Hill Aug 5 '11 at 22:57
Some have some don't, I would try another Dell AC adapter. – Moab Aug 5 '11 at 23:16

You can only charge a batter if

  1. the power manager chip thinks your power adapter has extra juice to charge the battery and
  2. battery reports it can be charged.

Charging a battery without enough current may reduce its life, so if your computer is under heavy load, the chip may choose to stop charging or even draw power from the battery.

Lithium batteries have a narrow operation temperature range. If it's too cold or hot, safety mechanisms will prevent charging.

Of course, the power adapter, the manager chip or the battery may be faulty.

share|improve this answer

Update your BIOS.

It has fixed this issue for me a few times. Especially if you are using the factory Dell charger. This also works for the after-market adapter as well.

share|improve this answer
  1. Check the AC adapter - it should have 19volts DC with at least 90 watts output. If it is less than 19 volts or if it is less than 90 watts it may power the laptop up, but not charge it.

  2. Remove the battery. Plug in the AC Adapter. Turn on computer. If the computer won't start up only on AC power, you're toast. Try with their original AC adapter, or call around for your friends - MOST Dells use the same power adapter. Try an original adapter of at least 90 watts.

  3. If it boots, go into the BIOS setup using the F2 key. Go into the POST Behavior screen. Look for Adapter. This setting either warns you the power supply is inadequate or doesn't. Make sure it is enabled. Reboot, do you get a warning message on bootup that the power supply is inadequate?

Let us know how things work out.

share|improve this answer

Fully discharge the battery by running the computer on battery mode and then remove and re-fix the battery. Then charge the battery for more than one hour (if the battery is working, charging light will be off after charged) and then switch on.

share|improve this answer

I tried all of the above with no success. I ended up replacing the power jack which comes in the form of an actual board.

The old board had an obvious burn out on one of the pins so my hopes for success increased at that point. Put everything back together plugged in the charger and wallah! Fixed! Finally!

share|improve this answer

You must log in to answer this question.

protected by studiohack May 24 '12 at 1:57

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .