Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Does anyone know how to set the port for the email server in the Status->Log section of the D-Link DI-524?

I’ve tried the setting below but it does not seem to work. I don’t want to use the default port 25 if I can avoid it. (No, the server and email address in the snap are irrelevant, you can replace the server with hotmail.com or whatever and address with a valid one; the question I am trying to figure out is how to set the port.)

DI-524 email logs page

share|improve this question
    
All I can suggest is try a space instead of a colon... If that doesn't work, I'm out of suggestions (short of rooting it/changing internal config files) –  William Hilsum Aug 6 '11 at 5:51
    
I don’t know how that would work since the firmware files are encoded/encrypted. –  Synetech Aug 6 '11 at 5:53
    
Most routers have a way of telnet'ing in and changing the config files... you may want to have a look in advanced and see if you can download a settings file, and then see if port is in there, then reupload. –  William Hilsum Aug 6 '11 at 9:59
    
I tried it, but it could not connect. I’ll see if I can look around for info on telnetting into this router, but I’m not getting my hopes up. –  Synetech Aug 6 '11 at 19:07

1 Answer 1

Unless you can telnet as William said (and I have my doubts there would be a lot more options there anyway), I seriously doubt that you are going to be able to set the port. These home devices are just not made to be very sophisticated or granular. The other problem is that when you have to set a port, it is usually for this reason: The ISP is trying to limit SPAM, and what do they do? They also make you authenticate with a username and password (for example, from within Outlook), and that option is clearly not there.

You also need to realize that you can't just replace that server with anything as you said. Hotmail.com is not going to work since there is no way they relay mail (they send for you, but only directly from their accounts, not relaying from another source). That field is for a server that will replay your mail, and your options are limited there.

You can do one of the following for that field:

  1. See if your ISP has an e-mail server that will relay for you that authenticates based on subnet (in other words, they see that the originating IP is one of theirs, so they just assume you are OK to relay). Otherwise, you are again in the situation where you don't have the fields necessary to authenticate. That said, most ISP's have stopped offering this service to home customers, but even most business customers still have to provide credentials. I am assuming this is on residential service based on the router.
  2. Try a proxy service, but I think you will again has the same problems with authentication.
  3. If you have a server, set up your own mailer, like from within Windows Server 2003 in IIS. This is your best best.

That router was discontinued back in 2008, and developed long before that, when some ISP's still had these relay servers. I think that most home user will now find this type of feature much more difficult to use now, especially if they do not have the option to enter credentials.

My suggestion is to try getting it to work on port 25 first, so you can get the server relay issue addressed first, which is probably an even bigger issue, and then see if you can change the port.

share|improve this answer
    
I’m using a local SMTP server and while I can set it to use port 25 and no login, I was really hoping to use a different port and authentication. I suppose I might have to decide between using a different port for the SMTP server and getting router logs (though I’m almost certain that I already had the authentication active and router logs at the same time). –  Synetech Aug 6 '11 at 19:07
    
@Synetech inc. You are one of the more sophisticated users here, so I am not surprised that you would have your own internal SMTP mailer, but I could not be sure. Most people would be pounding their head against the wall with no solution in sight. –  KCotreau Aug 6 '11 at 21:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.