Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have connected this Apple Aluminum keyboard to my Ubuntu-running PC. The thing is, F (function) keys are not working as I want them to work. There are eject key, and volume keys (keys with icons), they do eject and rise/lower volume – but I need the F functionality.

share|improve this question
add comment

1 Answer

up vote 2 down vote accepted

There are three modes according to the Ubuntu help:

  • 0 – Disable the 'fn' key. Pressing 'fn'+'F8' will behave like you only press 'F8'
  • 1 – Function keys are used as last key. Pressing 'F8' key will act as a special key. Pressing 'fn'+'F8' will behave like a F8.
  • 2 – Function keys are used as first key. Pressing 'F8' key will behave like a F8. Pressing 'fn'+'F8' will act as special key (play/pause).

It sounds like you want mode 2.


Change the setting temporarily by entering the following into a Terminal:

echo <n> | sudo tee /sys/module/hid_apple/parameters/fnmode

where <n> is either 0, 1 or 2 depending on the option you want to enable.

If you want to change it permanently, enter the following:

sudo sed -i -e 's#^exit 0$#echo <n> > /sys/module/hid_apple/parameters/fnmode\n&#g' /etc/rc.local

again, replacing <n> with 0, 1, or 2.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.