Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an Asus Z68 Motherboard on an existing system running Windows 7 x64. I now want to install an OCZ Agility 3 SSD to make use of the Intel Smart Response Technology. Apparently, it's not an easy task.

To begin with, I installed the latest version of the Intel Rapid Storage Technology from the Asus website. Following these instructions, I then installed the latest BIOS version, changed my SATA mode to RAID and rebooted:

(1) Enter OS, and ensure Intel Smart Response Technology has been turned off under Intel Rapid Storage Technology interface.

(2) Install version Intel Rapid Storage Technology driver to version 10.6.0.1002.

(3) Reboot the system, and update BIOS to version 0403, then reboot.

(4) Enter the BIOS setup screen, press F5 to load BIOS default, then change the Intel SATA Port to RAID mode.

(5) Boot into OS, and re-enable Intel Smart Response Technology under Intel Rapid Storage Technology.

This resulted in a blue screen of death, problem being Windows was installed in the default AHCI mode. To prevent this, I rebooted in AHCI to make the following changes to the registry, then returned to RAID mode:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Msahci\Start :: set to 0
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Pciide\Start  :: set to 0
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\iaStorV :: set to 0

(Note: At this stage I don't have a RAID array, just both disks running in a RAID environment, if that's the correct terminology.) All is now well, but when re-enabled Intel RST I still don't see an "Acceleration" tab. Instead in the management tab it just shows both the HDD and SDD are unknown in port and size, only the serial numbers are shown.

Does anyone have any idea how to fix this and set it up properly?

Can't post own answer yet, so:

Well, looks like I managed to find the problem. I did reinstall the Intel iRST drivers for a second time earlier in the process, just to ensure they were working, but third time was a charm. Helps when you make the obvious realisation I made in my comment regarding the original post.

Looks like a few people have resolved issues by upgrading/reinstalling the driver: http://www.ocztechnologyforum.com/forum/showthread.php?74090-Intel-Rapid-Storage-Technology-Status-shows-all-drives-0-GB http://arstechnica.com/civis/viewtopic.php?f=15&t=1151283

share|improve this question
    
Noting for myself here as much as anyone else - Intel SRT requires a minimum of a bit over 18GB to initialise. So, even if what I have done will indeed allow SRT to run properly, the fact that the RST shows the drives as 0GB would prevent this anyway. –  lpd Aug 6 '11 at 12:43
    
Had this exact same problem. Just like you, I only had to reinstall the iRST drivers. What a relief –  Brian Gordon Jul 30 '12 at 1:19
add comment

1 Answer

up vote 1 down vote accepted

You could check if the disk is using the Intel driver or the (default) Microsoft one. Go the Device Manager, double click the Controller in question and make sure the used drive is iaStore.

Device Manager Screenshot

share|improve this answer
    
Driver location is C:\...\iaStorV.sys. Not sure what the V on the end is, but I presume it's still Intel? (Well, it's provided by Intel corporation, so I know it is...) –  lpd Aug 6 '11 at 12:23
    
And while I'm at it I'll just accept your answer to mark it closed, thanks so much for helping! :) –  lpd Aug 6 '11 at 12:57
    
Thank you, you're welcome. –  TeX HeX Aug 8 '11 at 8:43
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.