Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have the following line in /etc/fstab

/dev/sdb3      /media/mybook    xfs     rw,auto,users                  0        0

The device is properly mounted and seen by root, but not by the normal user:

$ ls -al /media/
drwx-w---- 17  500 users 4096 2011-08-02 18:56 mybook

What should be changed in fstab to make it mount as rw for the normal user?

share|improve this question
up vote 0 down vote accepted
sudo chmod a=rwx /media/mybook

The permission bits are stored on disk with XFS, you cannot override them with mount options.

share|improve this answer
    
thank you, it really helped. I assume that I should probably chown it as well, as it stores uid (500) from the old system – Guard Aug 6 '11 at 15:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .