Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a Intel Core i7 system, ASRock MoBo, triple channel memory, EVGA graphics card.

This is a ~2 year old build, that have been running perfectly until now.

Whenever I turn it on, it turns off again within 20-30 seconds. Only once have I seen the ASRock bios splash screen appear.

I have tried to disconnect all drives, with no effect.

I don't know if the PC speaker is missing, but I wanted to see if it would beep when the memory or graphics card is missing - it never did, so don't know what's wrong.

Even if I keep hitting the reset button the stop it from starting boot, it still turns off after 20-30 seconds.

What do you think? Is it the PSU that fails?

share|improve this question
Try reseating your power connections to the motherboard (Not sure if there is only two, but at least that many). Next, you would try a new PSU, then MoBo. My best guess is that if the connections are seated correctly, then it is the PSU. If this works, I will move it to an answer. – KCotreau Aug 6 '11 at 13:23
PSU sounds like good first bet – Kris C Aug 6 '11 at 13:25
Was it working previously and just started to do this, or is it a new build? If it worked until recently, what changed? If it's a new build, as KCotreau says make sure all the power connections are seated properly, especially the graphics card - some modern graphics cards require two power connections, check both. Does your PSU have enough watts for the graphics card? – cantfork Aug 6 '11 at 14:19
Hi. Typical, I always forget to provide some obvious details. This is a ~2 year old build, which have been running perfectly until this happened. Nothing was changed to the system. – MartinHN Aug 6 '11 at 15:47

I suspect that one or more of the following things may be happening:

  • The power connections to the motherboard have come loose. This is the most likely problem, especially if the machine has been moved around at all. Make sure that plastic retaining clip is completely latched. Obviously you will know your system's specifics, but make sure you check all the power connections, including any separate 4-pin connector.

  • Your thermal paste has gone bad. Given enough time, and possibly exacerbated by quick cycles between high- and no-load, the thermal paste between the processor and cooling system will stop working properly. If this is the case, your processor's thermal protection is kicking in and shutting the machine down to prevent damage. The best way I have found to check for this is by replacing the paste, since removing the cooling system to check will require replacing the paste anyway.

  • Your power supply has gone bad. This is extremely unlikely, unless your power supply is from a shoddy manufacturer, but could always be an option. Checking output voltages with a multimeter will tell you if the supply is, in fact, dying, but simply replacing the PSU is the easiest method.

share|improve this answer

Check that the the retention screws are not over-tightened.

I had the same issue when replacing a CPU cooler. After loosening all four screws my system booted and worked normally.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .