Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Just recently I purchased Asus pro36sd laptop which comes with an onboard Intel graphic card and an nVidia dedicated one (GT520M), right after purchasing, I decided to change the OS that comes with it (Windows 7 Home Premium) with my Windows 7 professional. However after installation, my Windows performance index drops to 4.7 (it was 5.9 out of the box), after digging further, I noticed that the test was done using the Intel onboard graphic card instead of the dedicated one.

Dxdiag is also detecting that my main graphic card is Intel, I know this is not a big issue, but is there a way where I can tell Windows to use dedicated VGA card instead of the onboard one?

enter image description here

share|improve this question
add comment

3 Answers

up vote 0 down vote accepted

However after installation, my windows performance index drops to 4.7 (it was 5.9 out of the box),

Are you sure this is not caused by a difference in the video drivers? Perhaps the original install had up-to-date drivers, whereas the re-install has reverted to older/slower drivers.

I could be wrong, but I would not have expected that the primary adapter to change due to an operating system install.

It is years, since I have dealt with this issue, but there used to be a setting in the BIOS that allowed you to set the primary video adapter (and usually an option to disable the on-board video adapter if any). (For machines without on-board video cards and without the bios option, the primary adapter was determined by which slot the card was plugged into).

Once you get into windows, I'm not sure how important it is to be the Primary Video Adapter (other than perhaps for performance tests), since if anything appears on a monitor that is connected to the new video card, then windows is obviously using it.

share|improve this answer
    
Nope, I went to ASUS support website and re-downloaded the driver from the website, so if any, the driver that comes with the laptop should possibly be the least updated one. Yeah which is why I said it's not actually a biggie, but just in case any of you knows of a quick solution ;) –  andreas Aug 6 '11 at 17:33
add comment

Could you not just disable the onboard graphics adapter in Device Manager?

share|improve this answer
    
Oh yes I tried that out of desperation this morning, but it will just make my monitor practically useless I had to boot into safe mode and re-enable it back.... –  andreas Aug 6 '11 at 15:48
    
That sounds odd. Are you using your nVidia card for graphics at the moment? Does it show from boot? –  Joe Taylor Aug 7 '11 at 1:33
    
I think the main graphics card used by windows is still the onboard one, so when I disable the intel one, it just shuts down the monitor. –  andreas Aug 7 '11 at 3:49
    
What is the monitor plugged into though? –  Joe Taylor Aug 7 '11 at 17:39
    
Sorry forgot to mention that this is a laptop, I'll edit my question –  andreas Aug 8 '11 at 6:40
add comment

Check your system BIOS. It may have an option for the preferred video card, or even to disable on-board video entirely.

share|improve this answer
    
Good idea, will have a look onto the bios. Although I'm more inclined to think that it's the OS :( Thanks anyway ! :D –  andreas Aug 8 '11 at 8:00
    
unfortunately there's no option to set preferred VGA :(, thanks for the idea tho –  andreas Aug 8 '11 at 19:33
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.