Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I upgraded VirtualBox and am now unable to run a saved machine because of USB 2.0.

When I tried to resolve the problem by installing the VirtualBox extension pack I get the error Incompatible library version: VBoxPuelMain.dylib requires version 4.1.0 or later, but VBoxVMM.dylbin provides version 4.0.12.

share|improve this question

migrated from serverfault.com Aug 6 '11 at 22:52

This question came from our site for professional system and network administrators.

3 Answers 3

up vote 1 down vote accepted

Make sure that you have the correct extensions installed, since they're not automatically upgraded with VirtualBox. You can check in VBox from the menu... File > Preferences > Extensions.

Here are the latest downloads... http://www.virtualbox.org/wiki/Downloads

share|improve this answer

You are probably trying to install the extension of a newer VBox (I did the same :P). You have 2 options:

1 - download the right version in this link http://download.virtualbox.org/virtualbox/4.0.12/Oracle_VM_VirtualBox_Extension_Pack-4.0.12-72916.vbox-extpack;

2 - download a newer version of VirtualBox (v4.1.2 at the moment - http://www.virtualbox.org/wiki/Downloads) and try to install the same extension you are getting this error.

I did the second option and it's working fine now ;-)

share|improve this answer

This problem to me is simple. Just go to the Menu bar (on the top of your desktop), then check for update. This will automatically download the most up to date version, and most importantly the extensions will then be downloaded and installed.

It worked for me very well.

Good luck.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.